Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "USB CEC Adaptor communication Library" |
| 2 | HOMEPAGE = "http://libcec.pulse-eight.com/" |
| 3 | |
| 4 | LICENSE = "GPLv2+" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=e61fd86f9c947b430126181da2c6c715" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 6 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame^] | 7 | DEPENDS = "p8platform udev ncurses swig-native python3" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 8 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 9 | DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11 libxrandr', '', d)}" |
| 10 | DEPENDS_append_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' userland', d)}" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 11 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame^] | 12 | PV = "4.0.2+gitr${SRCPV}" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 13 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame^] | 14 | SRCREV = "0a97062dd4b196ceeb003ec41841c7a7edc36dd1" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 15 | SRC_URI = "git://github.com/Pulse-Eight/libcec.git \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame^] | 16 | file://0001-Explicitly-use-python3-in-pyCecClient.patch" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 17 | |
| 18 | S = "${WORKDIR}/git" |
| 19 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 20 | inherit cmake pkgconfig |
| 21 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame^] | 22 | # Put client tools into a separate package |
| 23 | PACKAGE_BEFORE_PN += "${PN}-tools" |
| 24 | FILES_${PN}-tools = "${bindir}" |
| 25 | RDEPENDS_${PN}-tools = "python3-${BPN}" |
| 26 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 27 | # Create the wrapper for python3 |
| 28 | PACKAGES += "python3-${BPN}" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame^] | 29 | FILES_python3-${BPN} = "${libdir}/python3* ${bindir}/py*" |
| 30 | RDEPENDS_${PN} = "python3-core" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 31 | |
| 32 | # cec-client and xbmc need the .so present to work :( |
| 33 | FILES_${PN} += "${libdir}/*.so" |
| 34 | INSANE_SKIP_${PN} = "dev-so" |
| 35 | |
| 36 | # Adapter shows up as a CDC-ACM device |
| 37 | RRECOMMENDS_${PN} = "kernel-module-cdc-acm" |