Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "A graphical front-end for gcov" |
| 2 | HOMEPAGE = "http://ltp.sourceforge.net/coverage/lcov.php" |
| 3 | DESCRIPTION = "LCOV is a graphical front-end for GCC's coverage testing \ |
| 4 | tool gcov. It collects gcov data for multiple source files and creates \ |
| 5 | HTML pages containing the source code annotated with coverage information. \ |
| 6 | It also adds overview pages for easy navigation within the file structure. \ |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 7 | LCOV supports statement, function and branch coverage measurement." |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 8 | LICENSE = "GPL-2.0" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 10 | |
| 11 | RDEPENDS_${PN} += " \ |
| 12 | gcov \ |
| 13 | perl \ |
| 14 | perl-module-filehandle \ |
| 15 | perl-module-getopt-std \ |
| 16 | perl-module-digest-sha \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame^] | 17 | perl-module-constant \ |
| 18 | perl-module-cwd \ |
| 19 | perl-module-errno \ |
| 20 | perl-module-file-basename \ |
| 21 | perl-module-file-find \ |
| 22 | perl-module-file-path \ |
| 23 | perl-module-file-spec \ |
| 24 | perl-module-file-spec-functions \ |
| 25 | perl-module-file-spec-unix \ |
| 26 | perl-module-file-temp \ |
| 27 | perl-module-getopt-long \ |
| 28 | perl-module-list-util \ |
| 29 | perl-module-mro \ |
| 30 | perl-module-overload \ |
| 31 | perl-module-overloading \ |
| 32 | perl-module-overload-numbers \ |
| 33 | perl-module-parent \ |
| 34 | perl-module-pod-usage \ |
| 35 | perl-module-posix \ |
| 36 | perl-module-re \ |
| 37 | perl-module-safe \ |
| 38 | perl-module-scalar-util \ |
| 39 | perl-module-term-cap \ |
| 40 | perl-module-text-parsewords \ |
| 41 | perl-module-tie-hash \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 42 | " |
| 43 | |
| 44 | SRC_URI = "http://downloads.sourceforge.net/ltp/${BP}.tar.gz" |
| 45 | |
| 46 | SRC_URI[md5sum] = "e79b799ae3ce149aa924c7520e993024" |
| 47 | SRC_URI[sha256sum] = "c282de8d678ecbfda32ce4b5c85fc02f77c2a39a062f068bd8e774d29ddc9bf8" |
| 48 | |
| 49 | do_install() { |
| 50 | oe_runmake install PREFIX=${D} |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 51 | } |
| 52 | |