Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame^] | 1 | SUMMARY = "Net::SSLeay - Perl extension for using OpenSSL" |
| 2 | DESCRIPTION = "This module offers some high level convenience functions for accessing \ |
| 3 | web pages on SSL servers (for symmetry, same API is offered for \ |
| 4 | accessing http servers, too), a sslcat() function for writing your own \ |
| 5 | clients, and finally access to the SSL api of SSLeay/OpenSSL package \ |
| 6 | so you can write servers or clients for more complicated applications." |
| 7 | HOMEPAGE = "http://search.cpan.org/dist/Net-SSLeay/" |
| 8 | SECTION = "libs" |
| 9 | |
| 10 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 11 | LIC_FILES_CHKSUM = "file://README;beginline=274;endline=294;md5=67d67095d83e339da538a082fad5f38e" |
| 12 | |
| 13 | DEPENDS = "openssl zlib openssl-native" |
| 14 | RDEPENDS_${PN} += "\ |
| 15 | libssl \ |
| 16 | libcrypto \ |
| 17 | perl-module-carp \ |
| 18 | perl-module-errno \ |
| 19 | perl-module-extutils-makemaker \ |
| 20 | perl-module-mime-base64 \ |
| 21 | perl-module-socket \ |
| 22 | zlib \ |
| 23 | " |
| 24 | |
| 25 | SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MI/MIKEM/Net-SSLeay-${PV}.tar.gz \ |
| 26 | file://no-exec-on-configure.patch \ |
| 27 | file://run-ptest \ |
| 28 | " |
| 29 | SRC_URI[md5sum] = "d602bdce4e0531c6efc276e3e429ca69" |
| 30 | SRC_URI[sha256sum] = "9d8188b9fb1cae3bd791979c20554925d5e94a138d00414f1a6814549927b0c8" |
| 31 | |
| 32 | S = "${WORKDIR}/Net-SSLeay-${PV}" |
| 33 | |
| 34 | inherit cpan ptest |
| 35 | |
| 36 | do_configure() { |
| 37 | export OPENSSL_PREFIX="${STAGING_EXECPREFIXDIR}" |
| 38 | cpan_do_configure |
| 39 | } |
| 40 | |
| 41 | do_install_ptest() { |
| 42 | cp -r ${B}/t ${D}${PTEST_PATH} |
| 43 | } |
| 44 | |
| 45 | BBCLASSEXTEND = "native" |
| 46 | |
| 47 | FILES_${PN}-dbg =+ "${libdir}/perl/vendor_perl/*/auto/Net/SSLeay/.debug/" |
| 48 | |
| 49 | RDEPENDS_${PN}-ptest = " perl" |