Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame^] | 1 | SUMMARY = "Python bindings for the DBus inter-process communication system" |
| 2 | SECTION = "devel/python" |
| 3 | HOMEPAGE = "http://www.freedesktop.org/Software/dbus" |
| 4 | LICENSE = "MIT & AFL-2.1 | GPLv2" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b03240518994df6d8c974675675e5ca4 \ |
| 6 | file://dbus-gmain/COPYING;md5=05c3eacd50f69bb1d58afec460baad57 " |
| 7 | DEPENDS = "expat dbus dbus-glib virtual/libintl python-pyrex-native" |
| 8 | |
| 9 | SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz \ |
| 10 | " |
| 11 | |
| 12 | SRC_URI[md5sum] = "7379db774c10904f27e7e2743d90fb43" |
| 13 | SRC_URI[sha256sum] = "abf12bbb765e300bf8e2a1b2f32f85949eab06998dbda127952c31cb63957b6f" |
| 14 | S = "${WORKDIR}/dbus-python-${PV}" |
| 15 | |
| 16 | inherit distutils-base autotools pkgconfig |
| 17 | |
| 18 | # documentation needs python-sphinx, which is not in oe-core or meta-python for now |
| 19 | # change to use PACKAGECONFIG when python-sphinx is added to oe-core or meta-python |
| 20 | EXTRA_OECONF += "--disable-documentation" |
| 21 | |
| 22 | export STAGING_LIBDIR |
| 23 | export STAGING_INCDIR |
| 24 | |
| 25 | RDEPENDS_${PN} = "python-io python-logging python-stringold python-threading python-xml" |
| 26 | |
| 27 | FILES_${PN}-dev += "${libdir}/pkgconfig" |
| 28 | |
| 29 | do_install_append() { |
| 30 | # Remove files that clash with python3-dbus; their content is same |
| 31 | rm ${D}${includedir}/dbus-1.0/dbus/dbus-python.h ${D}${libdir}/pkgconfig/dbus-python.pc |
| 32 | } |