blob: 26869a3a7dd59dec4e99bb22daec365ef6f6d285 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001From 91c0a0da2a8932f163d57db5d9d847bed6822502 Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Fri, 29 Jun 2018 15:59:57 +0800
4Subject: [PATCH] fix gcc7 ftbfs
5
6Upstream-Status: Pending [from debian]
7fix-gcc7-ftbfs.diff and rebase to 0.172
8
9http://ftp.de.debian.org/debian/pool/main/e/elfutils/elfutils_0.170-0.5.debian.tar.xz
10
11Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
12---
13 backends/mips_retval.c | 1 +
14 backends/parisc_retval.c | 1 +
15 src/ar.c | 2 +-
16 3 files changed, 3 insertions(+), 1 deletion(-)
17
18diff --git a/backends/mips_retval.c b/backends/mips_retval.c
19index 57487bb..e7973a8 100644
20--- a/backends/mips_retval.c
21+++ b/backends/mips_retval.c
22@@ -390,6 +390,7 @@ mips_return_value_location (Dwarf_Die *functypedie, const Dwarf_Op **locp)
23 }
24
25 /* Fallthrough to handle large types */
26+ /* Fall through. */
27
28 case DW_TAG_array_type:
29 large:
30diff --git a/backends/parisc_retval.c b/backends/parisc_retval.c
31index df7ec3a..988e1fe 100644
32--- a/backends/parisc_retval.c
33+++ b/backends/parisc_retval.c
34@@ -167,6 +167,7 @@ parisc_return_value_location_ (Dwarf_Die *functypedie, const Dwarf_Op **locp, in
35
36 /* Else fall through. */
37 }
38+ /* Fall through. */
39
40 case DW_TAG_structure_type:
41 case DW_TAG_class_type:
42diff --git a/src/ar.c b/src/ar.c
43index 818115b..c77e9f4 100644
44--- a/src/ar.c
45+++ b/src/ar.c
46@@ -1073,7 +1073,7 @@ do_oper_delete (const char *arfname, char **argv, int argc,
47 static bool
48 no0print (bool ofmt, char *buf, int bufsize, long int val)
49 {
50- char tmpbuf[bufsize + 1];
51+ char tmpbuf[bufsize + 1 + 4];
52 int ret = snprintf (tmpbuf, sizeof (tmpbuf), ofmt ? "%-*lo" : "%-*ld",
53 bufsize, val);
54 if (ret >= (int) sizeof (tmpbuf))
55--
562.7.4
57