Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame^] | 1 | SUMMARY = "File classification tool" |
| 2 | DESCRIPTION = "File attempts to classify files depending \ |
| 3 | on their contents and prints a description if a match is found." |
| 4 | HOMEPAGE = "http://www.darwinsys.com/file/" |
| 5 | SECTION = "console/utils" |
| 6 | |
| 7 | # two clause BSD |
| 8 | LICENSE = "BSD" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;beginline=2;md5=6a7382872edb68d33e1a9398b6e03188" |
| 10 | |
| 11 | DEPENDS = "zlib file-replacement-native" |
| 12 | DEPENDS_class-native = "zlib-native" |
| 13 | |
| 14 | # Blacklist a bogus tag in upstream check |
| 15 | UPSTREAM_CHECK_GITTAGREGEX = "FILE(?P<pver>(?!6_23).+)" |
| 16 | |
| 17 | SRC_URI = "git://github.com/file/file.git \ |
| 18 | file://debian-742262.patch \ |
| 19 | " |
| 20 | |
| 21 | SRCREV = "315cef2f699da3c31a54bd3c6c6070680fbaf1f5" |
| 22 | S = "${WORKDIR}/git" |
| 23 | |
| 24 | inherit autotools update-alternatives |
| 25 | |
| 26 | ALTERNATIVE_${PN} = "file" |
| 27 | ALTERNATIVE_LINK_NAME[file] = "${bindir}/file" |
| 28 | |
| 29 | EXTRA_OEMAKE_append_class-target = "-e FILE_COMPILE=${STAGING_BINDIR_NATIVE}/file-native/file" |
| 30 | EXTRA_OEMAKE_append_class-nativesdk = "-e FILE_COMPILE=${STAGING_BINDIR_NATIVE}/file-native/file" |
| 31 | |
| 32 | CFLAGS_append = " -std=c99" |
| 33 | |
| 34 | FILES_${PN} += "${datadir}/misc/*.mgc" |
| 35 | |
| 36 | do_install_append_class-native() { |
| 37 | create_cmdline_wrapper ${D}/${bindir}/file \ |
| 38 | --magic-file ${datadir}/misc/magic.mgc |
| 39 | } |
| 40 | |
| 41 | do_install_append_class-nativesdk() { |
| 42 | create_cmdline_wrapper ${D}/${bindir}/file \ |
| 43 | --magic-file ${datadir}/misc/magic.mgc |
| 44 | } |
| 45 | |
| 46 | BBCLASSEXTEND = "native nativesdk" |
| 47 | PROVIDES_append_class-native = " file-replacement-native" |
| 48 | # Don't use NATIVE_PACKAGE_PATH_SUFFIX as that hides libmagic from anyone who |
| 49 | # depends on file-replacement-native. |
| 50 | bindir_append_class-native = "/file-native" |