Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame^] | 1 | SUMMARY = "Perl module to manipulate and access URI strings" |
| 2 | DESCRIPTION = "This package contains the URI.pm module with friends. \ |
| 3 | The module implements the URI class. URI objects can be used to access \ |
| 4 | and manipulate the various components that make up these strings." |
| 5 | |
| 6 | HOMEPAGE = "http://search.cpan.org/dist/URI/" |
| 7 | SECTION = "libs" |
| 8 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 9 | |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c453e94fae672800f83bc1bd7a38b53f" |
| 11 | |
| 12 | DEPENDS += "perl" |
| 13 | |
| 14 | SRC_URI = "http://www.cpan.org/authors/id/E/ET/ETHER/URI-${PV}.tar.gz" |
| 15 | |
| 16 | SRC_URI[md5sum] = "892f7183b178af40f205ba37128225db" |
| 17 | SRC_URI[sha256sum] = "a9c254f45f89cb1dd946b689dfe433095404532a4543bdaab0b71ce0fdcdd53d" |
| 18 | |
| 19 | S = "${WORKDIR}/URI-${PV}" |
| 20 | |
| 21 | EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}" |
| 22 | |
| 23 | inherit cpan ptest-perl |
| 24 | |
| 25 | do_compile() { |
| 26 | export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')" |
| 27 | cpan_do_compile |
| 28 | } |
| 29 | |
| 30 | do_install_prepend() { |
| 31 | # these tests require "-T" (taint) command line option |
| 32 | rm -rf ${B}/t/cwd.t |
| 33 | rm -rf ${B}/t/file.t |
| 34 | } |
| 35 | |
| 36 | RDEPENDS_${PN}-ptest += "libtest-needs-perl" |
| 37 | |
| 38 | BBCLASSEXTEND = "native" |