Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame^] | 1 | SUMMARY = "Perl module for using and building Perl SAX2 XML processors" |
| 2 | HOMEPAGE = "http://search.cpan.org/dist/XML-SAX/" |
| 3 | DESCRIPTION = "XML::SAX consists of several framework classes for using and \ |
| 4 | building Perl SAX2 XML parsers, filters, and drivers. It is designed \ |
| 5 | around the need to be able to "plug in" different SAX parsers to an \ |
| 6 | application without requiring programmer intervention. Those of you \ |
| 7 | familiar with the DBI will be right at home. Some of the designs \ |
| 8 | come from the Java JAXP specification (SAX part), only without the \ |
| 9 | javaness." |
| 10 | |
| 11 | SECTION = "libs" |
| 12 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 13 | DEPENDS += "libxml-namespacesupport-perl-native" |
| 14 | RDEPENDS_${PN} += "libxml-namespacesupport-perl libxml-sax-base-perl perl-module-file-temp" |
| 15 | |
| 16 | LIC_FILES_CHKSUM = "file://LICENSE;md5=65c4cd8f39c24c7135ed70dacbcb09e3" |
| 17 | |
| 18 | SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GR/GRANTM/XML-SAX-${PV}.tar.gz" |
| 19 | |
| 20 | SRC_URI[md5sum] = "861a454f7bf269990ed2c1c125f4db48" |
| 21 | SRC_URI[sha256sum] = "45ea6564ef8692155d57b2de0862b6442d3c7e29f4a9bc9ede5d7ecdc74c2ae3" |
| 22 | |
| 23 | S = "${WORKDIR}/XML-SAX-${PV}" |
| 24 | |
| 25 | inherit cpan ptest-perl |
| 26 | |
| 27 | do_install_ptest() { |
| 28 | cp -r ${B}/testfiles ${D}${PTEST_PATH} |
| 29 | chown -R root:root ${D}${PTEST_PATH}/testfiles |
| 30 | } |
| 31 | |
| 32 | BBCLASSEXTEND = "native" |