Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | require cryptodev.inc |
| 2 | |
| 3 | SUMMARY = "A test suite for /dev/crypto device driver" |
| 4 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame^] | 5 | DEPENDS += "openssl" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 6 | |
| 7 | SRC_URI += " \ |
| 8 | file://0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame^] | 9 | file://0001-Port-tests-to-openssl-1.1.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 10 | " |
| 11 | |
| 12 | EXTRA_OEMAKE='KERNEL_DIR="${STAGING_EXECPREFIXDIR}" PREFIX="${D}"' |
| 13 | |
| 14 | do_compile() { |
| 15 | oe_runmake testprogs |
| 16 | } |
| 17 | |
| 18 | do_install() { |
| 19 | oe_runmake install_tests |
| 20 | } |
| 21 | |
| 22 | FILES_${PN} = "${bindir}/*" |