Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame^] | 1 | SUMMARY = "Python bindings for GStreamer 1.0" |
| 2 | HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-python/" |
| 3 | SECTION = "multimedia" |
| 4 | |
| 5 | LICENSE = "LGPLv2.1" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=c34deae4e395ca07e725ab0076a5f740" |
| 7 | |
| 8 | SRC_URI = "http://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz" |
| 9 | SRC_URI[md5sum] = "5b0af1bd490d79a7d435b2be47568f8e" |
| 10 | SRC_URI[sha256sum] = "dc40be5ab4f1a433ff3f0af2b3d2d79a363009020c41ec10f9747ba64200cb22" |
| 11 | |
| 12 | DEPENDS = "gstreamer1.0 python3-pygobject" |
| 13 | RDEPENDS_${PN} += "gstreamer1.0 python3-pygobject" |
| 14 | |
| 15 | PNREAL = "gst-python" |
| 16 | |
| 17 | S = "${WORKDIR}/${PNREAL}-${PV}" |
| 18 | |
| 19 | inherit autotools pkgconfig distutils3-base upstream-version-is-even gobject-introspection |
| 20 | |
| 21 | do_install_append() { |
| 22 | # gstpythonplugin hardcodes the location of the libpython from the build |
| 23 | # workspace and then fails at runtime. We can override it using |
| 24 | # --with-libpython-dir=${libdir}, but it still fails because it looks for a |
| 25 | # symlinked library ending in .so instead of the actually library with |
| 26 | # LIBNAME.so.MAJOR.MINOR. Although we could patch the code to use the path |
| 27 | # we want, it will break again if the library version ever changes. We need |
| 28 | # to think about the best way of handling this and possibly consult |
| 29 | # upstream. |
| 30 | # |
| 31 | # Note that this particular find line is taken from the Debian packaging for |
| 32 | # gst-python1.0. |
| 33 | find "${D}" \ |
| 34 | -name '*.pyc' -o \ |
| 35 | -name '*.pyo' -o \ |
| 36 | -name '*.la' -o \ |
| 37 | -name 'libgstpythonplugin*' \ |
| 38 | -delete |
| 39 | } |