Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame^] | 1 | SUMMARY = "VA-API support to GStreamer" |
| 2 | DESCRIPTION = "gstreamer-vaapi consists of a collection of VA-API \ |
| 3 | based plugins for GStreamer and helper libraries: `vaapidecode', \ |
| 4 | `vaapiconvert', and `vaapisink'." |
| 5 | |
| 6 | REALPN = "gstreamer-vaapi" |
| 7 | |
| 8 | LICENSE = "LGPLv2.1+" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c" |
| 10 | |
| 11 | SRC_URI = "https://gstreamer.freedesktop.org/src/${REALPN}/${REALPN}-${PV}.tar.xz \ |
| 12 | file://0001-gst-vaapi-Makefile.am-Add-EGL_CFLAGS-to-libgstvaapi-.patch \ |
| 13 | file://0001-vaapsink-downgrade-to-marginal.patch \ |
| 14 | " |
| 15 | |
| 16 | SRC_URI[md5sum] = "12ee9c16dfa0bb1808c76683e1c9a328" |
| 17 | SRC_URI[sha256sum] = "7f1064e27f5abd3a42ef66b425f1a2b9dbae7748c81bd9d090ce52a1aaf30d8a" |
| 18 | |
| 19 | S = "${WORKDIR}/${REALPN}-${PV}" |
| 20 | DEPENDS = "libva gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad" |
| 21 | |
| 22 | inherit autotools pkgconfig gtk-doc distro_features_check upstream-version-is-even |
| 23 | |
| 24 | REQUIRED_DISTRO_FEATURES ?= "opengl" |
| 25 | |
| 26 | PACKAGES =+ "${PN}-tests" |
| 27 | |
| 28 | # OpenGL packageconfig factored out to make it easy for distros |
| 29 | # and BSP layers to pick either glx, egl, or no GL. By default, |
| 30 | # try detecting X11 first, and if found (with OpenGL), use GLX, |
| 31 | # otherwise try to check if EGL can be used. |
| 32 | PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'glx', \ |
| 33 | bb.utils.contains('DISTRO_FEATURES', 'opengl', 'egl', \ |
| 34 | '', d), d)}" |
| 35 | |
| 36 | PACKAGECONFIG ??= "drm \ |
| 37 | ${PACKAGECONFIG_GL} \ |
| 38 | ${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}" |
| 39 | |
| 40 | PACKAGECONFIG[drm] = "--enable-drm,--disable-drm,udev libdrm" |
| 41 | PACKAGECONFIG[egl] = "--enable-egl,--disable-egl,virtual/egl" |
| 42 | PACKAGECONFIG[glx] = "--enable-glx,--disable-glx,virtual/libgl" |
| 43 | PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland" |
| 44 | PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxrandr libxrender" |
| 45 | |
| 46 | FILES_${PN} += "${libdir}/gstreamer-*/*.so" |
| 47 | FILES_${PN}-dbg += "${libdir}/gstreamer-*/.debug" |
| 48 | FILES_${PN}-dev += "${libdir}/gstreamer-*/*.la ${libdir}/gstreamer-*/*.a" |
| 49 | FILES_${PN}-tests = "${bindir}/*" |