blob: 64eb0c571f1db8d2271678266c5a4b0d477839de [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Interactive process viewer"
2HOMEPAGE = "http://hisham.hm/htop"
3SECTION = "console/utils"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=c312653532e8e669f30e5ec8bdc23be3"
6
7DEPENDS = "ncurses"
8
9SRC_URI = "http://hisham.hm/htop/releases/${PV}/${BP}.tar.gz \
Brad Bishop996bc452019-12-02 13:05:15 -050010 file://0001-Use-pkg-config.patch \
11 file://0001-Ask-for-python3-specifically.patch \
12 "
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013SRC_URI[md5sum] = "0d816b6beed31edc75babcfbf863ffa8"
14SRC_URI[sha256sum] = "d9d6826f10ce3887950d709b53ee1d8c1849a70fa38e91d5896ad8cbc6ba3c57"
15
16inherit autotools pkgconfig
17
18PACKAGECONFIG ??= "proc \
19 cgroup \
20 taskstats \
21 unicode \
22 linux-affinity \
23 delayacct"
24PACKAGECONFIG[proc] = "--enable-proc,--disable-proc"
25PACKAGECONFIG[openvz] = "--enable-openvz,--disable-openvz"
26PACKAGECONFIG[cgroup] = "--enable-cgroup,--disable-cgroup"
27PACKAGECONFIG[vserver] = "--enable-vserver,--disable-vserver"
28PACKAGECONFIG[taskstats] = "--enable-taskstats,--disable-taskstats"
29PACKAGECONFIG[unicode] = "--enable-unicode,--disable-unicode"
30PACKAGECONFIG[linux-affinity] = "--enable-linux-affinity,--disable-linux-affinity"
31PACKAGECONFIG[hwloc] = "--enable-hwloc,--disable-hwloc,hwloc"
32PACKAGECONFIG[setuid] = "--enable-setuid,--disable-setuid"
33PACKAGECONFIG[delayacct] = "--enable-delayacct,--disable-delayacct,libnl"
34
35do_configure_prepend () {
36 rm -rf ${S}/config.h
37}