Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Interactive process viewer" |
| 2 | HOMEPAGE = "http://hisham.hm/htop" |
| 3 | SECTION = "console/utils" |
| 4 | LICENSE = "GPLv2" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=c312653532e8e669f30e5ec8bdc23be3" |
| 6 | |
| 7 | DEPENDS = "ncurses" |
| 8 | |
| 9 | SRC_URI = "http://hisham.hm/htop/releases/${PV}/${BP}.tar.gz \ |
Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 10 | file://0001-Use-pkg-config.patch \ |
| 11 | file://0001-Ask-for-python3-specifically.patch \ |
| 12 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 13 | SRC_URI[md5sum] = "0d816b6beed31edc75babcfbf863ffa8" |
| 14 | SRC_URI[sha256sum] = "d9d6826f10ce3887950d709b53ee1d8c1849a70fa38e91d5896ad8cbc6ba3c57" |
| 15 | |
| 16 | inherit autotools pkgconfig |
| 17 | |
| 18 | PACKAGECONFIG ??= "proc \ |
| 19 | cgroup \ |
| 20 | taskstats \ |
| 21 | unicode \ |
| 22 | linux-affinity \ |
| 23 | delayacct" |
| 24 | PACKAGECONFIG[proc] = "--enable-proc,--disable-proc" |
| 25 | PACKAGECONFIG[openvz] = "--enable-openvz,--disable-openvz" |
| 26 | PACKAGECONFIG[cgroup] = "--enable-cgroup,--disable-cgroup" |
| 27 | PACKAGECONFIG[vserver] = "--enable-vserver,--disable-vserver" |
| 28 | PACKAGECONFIG[taskstats] = "--enable-taskstats,--disable-taskstats" |
| 29 | PACKAGECONFIG[unicode] = "--enable-unicode,--disable-unicode" |
| 30 | PACKAGECONFIG[linux-affinity] = "--enable-linux-affinity,--disable-linux-affinity" |
| 31 | PACKAGECONFIG[hwloc] = "--enable-hwloc,--disable-hwloc,hwloc" |
| 32 | PACKAGECONFIG[setuid] = "--enable-setuid,--disable-setuid" |
| 33 | PACKAGECONFIG[delayacct] = "--enable-delayacct,--disable-delayacct,libnl" |
| 34 | |
| 35 | do_configure_prepend () { |
| 36 | rm -rf ${S}/config.h |
| 37 | } |