Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | DESCRIPTION = "Eigen is a C++ template library for linear algebra: matrices, vectors, numerical solvers, and related algorithms." |
| 2 | AUTHOR = "Benoît Jacob and Gaël Guennebaud and others" |
| 3 | HOMEPAGE = "http://eigen.tuxfamily.org/" |
| 4 | LICENSE = "MPL-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING.MPL2;md5=815ca599c9df247a0c7f619bab123dad" |
| 6 | |
| 7 | SRC_URI = "https://bitbucket.org/eigen/eigen/get/${PV}.tar.bz2;downloadfilename=${BP}.tar.bz2" |
| 8 | SRC_URI[md5sum] = "05b1f7511c93980c385ebe11bd3c93fa" |
| 9 | SRC_URI[sha256sum] = "9f13cf90dedbe3e52a19f43000d71fdf72e986beb9a5436dddcd61ff9d77a3ce" |
| 10 | |
| 11 | S = "${WORKDIR}/eigen-eigen-323c052e1731" |
| 12 | |
| 13 | inherit cmake |
| 14 | |
| 15 | FILES_${PN} = "${libdir}" |
| 16 | FILES_${PN}-dev = "${includedir} ${datadir}/eigen3/cmake ${datadir}/cmake/Modules ${datadir}/pkgconfig" |
| 17 | |
| 18 | # ${PN} is empty so we need to tweak -dev and -dbg package dependencies |
| 19 | RDEPENDS_${PN}-dev = "" |
| 20 | RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})" |
Brad Bishop | b809eb9 | 2019-09-18 06:27:43 -0400 | [diff] [blame] | 21 | |
| 22 | BBCLASSEXTEND = "native nativesdk" |