Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 1 | require boost-${PV}.inc |
2 | |||||
3 | SUMMARY = "Portable Boost.Jam build tool for boost" | ||||
4 | SECTION = "devel" | ||||
5 | |||||
6 | inherit native | ||||
7 | |||||
8 | SRC_URI += "file://0001-Build-debug-version-of-bjam.patch \ | ||||
9 | file://0001-build.sh-use-DNDEBUG-also-in-debug-builds.patch \ | ||||
10 | " | ||||
11 | |||||
12 | do_compile() { | ||||
13 | ./bootstrap.sh --with-toolset=gcc | ||||
14 | } | ||||
15 | |||||
16 | do_install() { | ||||
17 | install -d ${D}${bindir}/ | ||||
18 | # install unstripped version for bjam | ||||
19 | install -c -m 755 b2 ${D}${bindir}/bjam | ||||
20 | } |