Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | DESCRIPTION = "The usermode contains the userhelper program, which can be used to allow configured \ |
| 2 | programs to be run with superuser privileges by ordinary users, and several \ |
| 3 | graphical tools for users: \ |
| 4 | * userinfo allows users to change their finger information. \ |
| 5 | * usermount lets users mount, unmount, and format filesystems. \ |
| 6 | * userpasswd allows users to change their passwords. \ |
| 7 | " |
| 8 | HOMEPAGE = "https://pagure.io/usermode" |
| 9 | LICENSE = "GPLv2+" |
| 10 | DEPENDS = "libuser ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)} \ |
| 11 | gtk+ desktop-file-utils-native \ |
| 12 | startup-notification intltool-native \ |
| 13 | util-linux \ |
| 14 | " |
| 15 | |
| 16 | SRC_URI = "https://releases.pagure.org/${BPN}/${BPN}-${PV}.tar.xz \ |
| 17 | file://0001-formatting-issues.patch \ |
| 18 | file://0001-fix-compile-failure-against-musl-C-library.patch \ |
| 19 | file://0001-Makefile.am-Link-with-libm-for-powl-API.patch \ |
| 20 | " |
| 21 | SRC_URI[md5sum] = "28ba510fbd8da9f4e86e57d6c31cff29" |
| 22 | SRC_URI[sha256sum] = "3dd0b9639b5bd396b7ea5fada6aaa694dbfdaa3ad06eb95a6eabcdfd02f875c6" |
| 23 | |
| 24 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552" |
| 25 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 26 | inherit distro_features_check autotools gettext pkgconfig |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 27 | |
| 28 | EXTRA_OEMAKE += "INSTALL='install -p'" |
| 29 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 30 | REQUIRED_DISTRO_FEATURES = "x11 pam" |