blob: bb28ee410c1c879db567c3cf58c175c5864d06f1 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "An abstraction layer for touchscreen panel events"
2DESCRIPTION = "Tslib is an abstraction layer for touchscreen panel \
3events, as well as a filter stack for the manipulation of those events. \
4Tslib is generally used on embedded devices to provide a common user \
5space interface to touchscreen functionality."
6HOMEPAGE = "http://tslib.org/"
7
8AUTHOR = "Martin Kepplinger <martink@posteo.de>"
9SECTION = "base"
10LICENSE = "LGPLv2+ & GPLv2+"
11LIC_FILES_CHKSUM = "\
12 file://COPYING;md5=fc178bcd425090939a8b634d1d6a9594 \
13 file://tests/COPYING;md5=a23a74b3f4caf9616230789d94217acb \
14"
15
16SRC_URI = "https://github.com/kergoth/tslib/releases/download/${PV}/tslib-${PV}.tar.xz;downloadfilename=tslib-${PV}.tar.xz \
Brad Bishope42b3e32020-01-15 22:08:42 -050017 file://0001-Fix-build-on-32bit-arches-with-64bit-time_t.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018 file://ts.conf \
19 file://tslib.sh \
20"
Brad Bishop2f973922019-11-11 07:58:48 -050021SRC_URI[md5sum] = "b2b20d3ed520128513f8d3135b42e142"
22SRC_URI[sha256sum] = "d2a57b823ea59e53a3b130eef05dfed1190b857854f886eec764e1ca1957cf56"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080023
24UPSTREAM_CHECK_URI = "https://github.com/kergoth/tslib/releases"
25
26inherit autotools pkgconfig
27
28PACKAGECONFIG ??= "debounce dejitter iir linear median pthres skip lowpass invert variance input touchkit waveshare"
29PACKAGECONFIG[debounce] = "--enable-debounce,--disable-debounce"
30PACKAGECONFIG[dejitter] = "--enable-dejitter,--disable-dejitter"
31PACKAGECONFIG[iir] = "--enable-iir,--disable-iir"
32PACKAGECONFIG[linear] = "--enable-linear,--disable-linear"
33PACKAGECONFIG[median] = "--enable-median,--disable-median"
34PACKAGECONFIG[pthres] = "--enable-pthres,--disable-pthres"
35PACKAGECONFIG[skip] = "--enable-skip,--disable-skip"
36PACKAGECONFIG[lowpass] = "--enable-lowpass,--disable-lowpass"
37PACKAGECONFIG[invert] = "--enable-invert,--disable-invert"
38PACKAGECONFIG[variance] = "--enable-variance,--disable-variance"
39PACKAGECONFIG[input] = "--enable-input,--disable-input"
40PACKAGECONFIG[tatung] = "--enable-tatung,--disable-tatung"
41PACKAGECONFIG[touchkit] = "--enable-touchkit,--disable-touchkit"
42PACKAGECONFIG[waveshare] = "--enable-waveshare,--disable-waveshare"
43PACKAGECONFIG[ucb1x00] = "--enable-ucb1x00,--disable-ucb1x00"
44PACKAGECONFIG[mk712] = "--enable-mk712,--disable-mk712"
45PACKAGECONFIG[h3600] = "--enable-h3600,--disable-h3600"
46PACKAGECONFIG[dmc] = "--enable-dmc,--disable-dmc"
47PACKAGECONFIG[linear-h2200] = "--enable-linear-h2200,--disable-linear-h2200"
48PACKAGECONFIG[corgi] = "--enable-corgi,--disable-corgi"
49PACKAGECONFIG[collie] = "--enable-collie,--disable-collie"
50PACKAGECONFIG[arctic2] = "--enable-arctic2,--disable-arctic2"
51PACKAGECONFIG[dmc_dus3000] = "--enable-dmc_dus3000,--disable-dmc_dus3000"
52PACKAGECONFIG[cy8mrln-palmpre] = "--enable-cy8mrln-palmpre,--disable-cy8mrln-palmpre"
53PACKAGECONFIG[galax] = "--enable-galax,--disable-galax"
54PACKAGECONFIG[debug] = "--enable-debug,--disable-debug"
55
56do_install_prepend() {
57 install -m 0644 ${WORKDIR}/ts.conf ${S}/etc/ts.conf
58}
59
60do_install_append() {
61 install -d ${D}${sysconfdir}/profile.d/
62 install -m 0755 ${WORKDIR}/tslib.sh ${D}${sysconfdir}/profile.d/
63}
64
65RPROVIDES_tslib-conf = "libts-0.0-conf"
66
67PACKAGES =+ "tslib-conf tslib-tests tslib-calibrate tslib-uinput"
68DEBIAN_NOAUTONAME_tslib-conf = "1"
69DEBIAN_NOAUTONAME_tslib-tests = "1"
70DEBIAN_NOAUTONAME_tslib-calibrate = "1"
71DEBIAN_NOAUTONAME_tslib-uinput = "1"
72
73RDEPENDS_${PN} = "tslib-conf"
74RRECOMMENDS_${PN} = "pointercal"
75
76FILES_${PN}-dev += "${libdir}/ts/*.la"
77FILES_tslib-conf = "${sysconfdir}/ts.conf ${sysconfdir}/profile.d/tslib.sh ${datadir}/tslib"
78FILES_${PN} = "${libdir}/*.so.* ${libdir}/ts/*.so*"
79FILES_tslib-calibrate += "${bindir}/ts_calibrate"
80FILES_tslib-uinput += "${bindir}/ts_uinput"
81
82FILES_tslib-tests = "${bindir}/ts_harvest ${bindir}/ts_print ${bindir}/ts_print_raw ${bindir}/ts_print_mt \
Brad Bishop2f973922019-11-11 07:58:48 -050083 ${bindir}/ts_test ${bindir}/ts_test_mt ${bindir}/ts_verify ${bindir}/ts_finddev ${bindir}/ts_conf"