blob: ffa03259f13117d52dab2a5c8de43e992c629ea1 [file] [log] [blame]
Tim Lee1c9c10a2022-07-05 17:14:18 +08001SUMMARY = "Image Generation and Programming Scripts for NPCM8XX (Arbel) devices"
2DESCRIPTION = "Image Generation and Programming Scripts for NPCM8XX (Arbel) devices"
3HOMEPAGE = "https://github.com/Nuvoton-Israel/igps-npcm8xx"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7SRC_URI = " \
8 git://github.com/Nuvoton-Israel/igps-npcm8xx;branch=main;protocol=https \
9 file://0001-Adjust-paths-for-use-with-Bitbake.patch \
10"
11
12# tag IGPS_03.06.02
13SRCREV = "6e6fbeb36a9a4652300560659fe695780b4ae71b"
14
15S = "${WORKDIR}/git"
16
17DEST = "${D}${datadir}/${BPN}"
18
19inherit deploy
20
21do_deploy () {
22 install -D -m 644 ${S}/py_scripts/ImageGeneration/output_binaries/Secure/Kmt_TipFwL0_Skmt_TipFwL1.bin ${DEPLOYDIR}/Kmt_TipFwL0_Skmt_TipFwL1.bin
23 install -D -m 644 ${S}/py_scripts/ImageGeneration/versions/arbel_a35_bootblock.0.2.2.bin ${DEPLOYDIR}/arbel_a35_bootblock.bin
24}
25
26addtask deploy before do_build after do_compile
27
28do_install() {
29 install -d ${DEST}
30 install py_scripts/ImageGeneration/references/BootBlockAndHeader_${DEVICE_GEN}_${IGPS_MACHINE}.xml ${DEST}
31 install py_scripts/ImageGeneration/references/UbootHeader_${DEVICE_GEN}.xml ${DEST}
32 install py_scripts/ImageGeneration/inputs/BL31_AndHeader.xml ${DEST}
33 install py_scripts/ImageGeneration/inputs/OpTeeAndHeader.xml ${DEST}
34}
35
36inherit native