Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Linux Trace Toolkit Userspace Tracer 2.x" |
| 2 | DESCRIPTION = "The LTTng UST 2.x package contains the userspace tracer library to trace userspace codes." |
| 3 | HOMEPAGE = "http://lttng.org/ust" |
| 4 | BUGTRACKER = "https://bugs.lttng.org/projects/lttng-ust" |
| 5 | |
| 6 | LICENSE = "LGPLv2.1+ & MIT & GPLv2" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=c963eb366b781252b0bf0fdf1624d9e9 \ |
| 8 | file://snprintf/snprintf.c;endline=32;md5=d3d544959d8a3782b2e07451be0a903c \ |
| 9 | file://snprintf/various.h;endline=31;md5=89f2509b6b4682c4fc95255eec4abe44" |
| 10 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 11 | PYTHON_OPTION = "am_cv_python_pyexecdir='${PYTHON_SITEPACKAGES_DIR}' \ |
| 12 | am_cv_python_pythondir='${PYTHON_SITEPACKAGES_DIR}' \ |
| 13 | PYTHON_INCLUDE='-I${STAGING_INCDIR}/python${PYTHON_BASEVERSION}${PYTHON_ABI}' \ |
| 14 | " |
| 15 | |
| 16 | inherit autotools lib_package manpages python3native |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 17 | |
| 18 | DEPENDS = "liburcu util-linux" |
| 19 | RDEPENDS_${PN}-bin = "python3-core" |
| 20 | |
| 21 | # For backwards compatibility after rename |
| 22 | RPROVIDES_${PN} = "lttng2-ust" |
| 23 | RREPLACES_${PN} = "lttng2-ust" |
| 24 | RCONFLICTS_${PN} = "lttng2-ust" |
| 25 | |
| 26 | PE = "2" |
| 27 | |
| 28 | SRC_URI = "https://lttng.org/files/lttng-ust/lttng-ust-${PV}.tar.bz2 \ |
| 29 | file://lttng-ust-doc-examples-disable.patch \ |
Brad Bishop | 00e122a | 2019-10-05 11:10:57 -0400 | [diff] [blame] | 30 | file://0001-python-lttngust-Makefile.am-Add-install-lib-to-setup.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 31 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 32 | |
Brad Bishop | a34c030 | 2019-09-23 22:34:48 -0400 | [diff] [blame] | 33 | SRC_URI[md5sum] = "f0c86a9fa7dcfd0205fb42584a310b1c" |
| 34 | SRC_URI[sha256sum] = "06f9ed9b2198855b1c7fcbf15fe57297ee259409ffa1b3bad87321412d98bc35" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 35 | |
| 36 | CVE_PRODUCT = "ust" |
| 37 | |
| 38 | PACKAGECONFIG[manpages] = "--enable-man-pages, --disable-man-pages, asciidoc-native xmlto-native libxslt-native" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 39 | PACKAGECONFIG[python3-agent] = "--enable-python-agent ${PYTHON_OPTION}, --disable-python-agent, python3, python3" |
| 40 | |
| 41 | FILES_${PN} += " ${PYTHON_SITEPACKAGES_DIR}/*" |
| 42 | FILES_${PN}-staticdev += " ${PYTHON_SITEPACKAGES_DIR}/*.a" |
| 43 | FILES_${PN}-dev += " ${PYTHON_SITEPACKAGES_DIR}/*.la" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 44 | |
| 45 | do_install_append() { |
| 46 | # Patch python tools to use Python 3; they should be source compatible, but |
| 47 | # still refer to Python 2 in the shebang |
| 48 | sed -i -e '1s,#!.*python.*,#!${bindir}/python3,' ${D}${bindir}/lttng-gen-tp |
| 49 | } |