Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | DESCRIPTION = "Parallelism library for C++ - runtime files \ |
| 2 | TBB is a library that helps you leverage multi-core processor \ |
| 3 | performance without having to be a threading expert. It represents a \ |
| 4 | higher-level, task-based parallelism that abstracts platform details \ |
| 5 | and threading mechanism for performance and scalability." |
| 6 | HOMEPAGE = "https://software.intel.com/en-us/tbb" |
| 7 | LICENSE = "Apache-2.0" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=86d3f3a95c324c9479bd8986968f4327" |
| 9 | |
| 10 | DEPENDS:append:libc-musl = " libucontext" |
| 11 | |
| 12 | PE = "1" |
| 13 | |
| 14 | BRANCH = "onetbb_2021" |
| 15 | SRCREV = "3df08fe234f23e732a122809b40eb129ae22733f" |
| 16 | SRC_URI = "git://github.com/oneapi-src/oneTBB.git;protocol=https;branch=${BRANCH} \ |
| 17 | file://0001-mallinfo-is-glibc-specific-API-mark-it-so.patch \ |
| 18 | file://0001-CMakeLists.txt-exclude-riscv64-riscv32.patch \ |
| 19 | file://0001-Disable-use-of-_tpause-instruction.patch \ |
| 20 | file://0001-Musl-linux-can-not-use-RTLD_DEEPBIND.patch \ |
| 21 | file://0001-Disable-LTO-on-clang-riscv32.patch \ |
| 22 | " |
| 23 | |
| 24 | S = "${WORKDIR}/git" |
| 25 | |
| 26 | inherit cmake |
| 27 | |
| 28 | # test build fails, error: 'mallinfo mallinfo()' is deprecated |
| 29 | EXTRA_OECMAKE += " \ |
| 30 | -DTBB_TEST=OFF \ |
| 31 | -DCMAKE_BUILD_TYPE=Release \ |
| 32 | " |
| 33 | |
| 34 | |
| 35 | # fails with thumb enabled: |
| 36 | # | arm-oe-linux-gnueabi-g++ -march=armv7-a -mthumb -mthumb-interwork -mfloat-abi=softfp -mfpu=neon -mtune=cortex-a9 -mcpu=cortex-a9 -D__ARM__ -D__LINUX_ARM_ARCH__=7 -funwind-tables -mvectorize-with-neon-quad -rdynamic --sysroot=/OE/sysroots/m14tv -c -MMD -DTBB_USE_DEBUG -g -O0 -DUSE_PTHREAD -fPIC -D__TBB_BUILD=1 -Wall -Wno-parentheses -Wno-non-virtual-dtor -O2 -pipe -g -feliminate-unused-debug-types -fpermissive -fvisibility-inlines-hidden -I../../src -I../../src/rml/include -I../../include ../../src/tbb/concurrent_queue.cpp |
| 37 | # | {standard input}: Assembler messages: |
| 38 | # | {standard input}:250: Error: thumb conditional instruction should be in IT block -- `strexeq r2,r3,[r4]' |
| 39 | # ... |
| 40 | # | make[1]: *** [concurrent_queue.o] Error 1 |
| 41 | ARM_INSTRUCTION_SET = "arm" |
| 42 | |
| 43 | ASNEEDED = "" |
| 44 | |
| 45 | LDFLAGS:append:mips = " -latomic" |
| 46 | LDFLAGS:append:mipsel = " -latomic" |
| 47 | LDFLAGS:append:riscv32:toolchain-clang = " -latomic" |
| 48 | |
| 49 | LDFLAGS:append:libc-musl = " -lucontext" |
| 50 | |
| 51 | # The latest version of oneTBB does not support PPC |
| 52 | COMPATIBLE_MACHINE:powerpc = "(!.*ppc).*" |
| 53 | |
| 54 | BBCLASSEXTEND = "native nativesdk" |