Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | # NOTE: |
| 2 | # You should use perl-module-encode rather than this package |
| 3 | # unless you specifically need a version newer than what is |
| 4 | # provided by perl. |
| 5 | |
| 6 | SUMMARY = "Encode - character encodings" |
| 7 | DESCRIPTION = "The \"Encode\" module provides the interfaces between \ |
| 8 | Perl's strings and the rest of the system. Perl strings are sequences \ |
| 9 | of characters." |
| 10 | |
| 11 | AUTHOR = "Dan Kogai <dankogai+cpan@gmail.com>" |
| 12 | HOMEPAGE = "https://metacpan.org/release/Encode" |
| 13 | SECTION = "lib" |
| 14 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 15 | LIC_FILES_CHKSUM = "file://META.json;md5=d8e909447b983532b2b460c830e7a7e4" |
| 16 | |
| 17 | SRC_URI = "${CPAN_MIRROR}/authors/id/D/DA/DANKOGAI/Encode-${PV}.tar.gz" |
| 18 | SRC_URI[md5sum] = "f995e0eb9e52d01ed57abe835bf3ccb6" |
| 19 | SRC_URI[sha256sum] = "acb3a4af5e3ee38f94de8baa7454e0b836a0649e7ac4180f28dfca439ad60cff" |
| 20 | |
| 21 | UPSTREAM_CHECK_REGEX = "Encode\-(?P<pver>(\d+\.\d+))(?!_\d+).tar" |
| 22 | |
| 23 | S = "${WORKDIR}/Encode-${PV}" |
| 24 | |
| 25 | inherit cpan |
| 26 | |
| 27 | # file /usr/bin/enc2xs from install of perl-misc-5.24.1-r0.i586 conflicts with file from package libencode-perl-2.94-r0.i586 |
| 28 | # file /usr/bin/encguess from install of perl-misc-5.24.1-r0.i586 conflicts with file from package libencode-perl-2.94-r0.i586 |
| 29 | # file /usr/bin/piconv from install of perl-misc-5.24.1-r0.i586 conflicts with file from package libencode-perl-2.94-r0.i586 |
| 30 | RCONFLICTS_${PN} = "perl-misc" |
| 31 | |
| 32 | RDEPENDS_${PN} += " perl-module-bytes \ |
| 33 | perl-module-constant \ |
| 34 | perl-module-parent \ |
| 35 | perl-module-storable \ |
| 36 | perl-module-xsloader \ |
| 37 | " |
| 38 | |
| 39 | RPROVIDES_${PN} += "libencode-alias-perl \ |
| 40 | libencode-byte-perl \ |
| 41 | libencode-cjkconstants-perl \ |
| 42 | libencode-cn-perl \ |
| 43 | libencode-cn-hz-perl \ |
| 44 | libencode-config-perl \ |
| 45 | libencode-ebcdic-perl \ |
| 46 | libencode-encoder-perl \ |
| 47 | libencode-encoding-perl \ |
| 48 | libencode-gsm0338-perl \ |
| 49 | libencode-guess-perl \ |
| 50 | libencode-jp-perl \ |
| 51 | libencode-jp-h2z-perl \ |
| 52 | libencode-jp-jis7-perl \ |
| 53 | libencode-kr-perl \ |
| 54 | libencode-kr-2022_kr-perl \ |
| 55 | libencode-mime-header-perl \ |
| 56 | libencode-mime-name-perl \ |
| 57 | libencode-symbol-perl \ |
| 58 | libencode-tw-perl \ |
| 59 | libencode-unicode-perl \ |
| 60 | libencode-unicode-utf7-perl \ |
| 61 | libencoding-perl \ |
| 62 | libencode-internal-perl \ |
| 63 | libencode-mime-header-iso_2022_jp-perl \ |
| 64 | libencode-utf8-perl \ |
| 65 | libencode-utf_ebcdic-perl \ |
| 66 | " |
| 67 | |
| 68 | BBCLASSEXTEND = "native" |