Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "The GNU portability library" |
| 2 | DESCRIPTION = "A collection of software subroutines which are designed to \ |
| 3 | be usable on many operating systems. The goal of the project \ |
| 4 | is to make it easy for free software authors to make their \ |
| 5 | software run on many operating systems. Since source is designed \ |
| 6 | to be copied from gnulib, it is not a library per-se, as much \ |
| 7 | as a collection of portable idioms to be used in other projects." |
| 8 | |
| 9 | HOMEPAGE = "http://www.gnu.org/software/gnulib/" |
| 10 | SECTION = "devel" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 11 | LICENSE = "LGPL-2.0-or-later" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 12 | |
| 13 | LIC_FILES_CHKSUM = "file://COPYING;md5=56a22a6e5bcce45e2c8ac184f81412b5" |
| 14 | SRCREV = "0d6e3307bbdb8df4d56043d5f373eeeffe4cbef3" |
| 15 | |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 16 | SRC_URI = "git://git.savannah.gnu.org/git/gnulib.git;branch=master \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 17 | " |
| 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 21 | do_install () { |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 22 | install -d ${D}/${datadir}/gnulib |
| 23 | cp --no-preserve=ownership --recursive ${S}/* ${D}/${datadir}/gnulib/ |
| 24 | cp --no-preserve=ownership --recursive ${S}/.git ${D}/${datadir}/gnulib/ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 25 | } |
| 26 | |
| 27 | do_patch[noexec] = "1" |
| 28 | do_configure[noexec] = "1" |
| 29 | do_compile[noexec] = "1" |
| 30 | do_package[noexec] = "1" |
| 31 | do_packagedata[noexec] = "1" |
| 32 | deltask package_write_ipk |
| 33 | deltask package_write_deb |
| 34 | deltask package_write_rpm |
| 35 | deltask do_deploy_archives |
| 36 | |
| 37 | BBCLASSEXTEND = "native" |