Willy Tu | 1fe95d5 | 2021-02-09 12:41:44 -0800 | [diff] [blame^] | 1 | PR = "r1" |
| 2 | |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 5 | |
| 6 | inherit systemd |
| 7 | |
| 8 | RDEPENDS_${PN} += "iperf3" |
| 9 | |
| 10 | SRC_URI += "file://iperf3.service" |
| 11 | |
| 12 | SYSTEMD_SERVICE_${PN} += "iperf3.service" |
| 13 | |
| 14 | do_install() { |
| 15 | # Install service definitions |
| 16 | install -d -m 0755 ${D}${systemd_system_unitdir} |
| 17 | install -m 0644 ${WORKDIR}/iperf3.service ${D}${systemd_system_unitdir} |
| 18 | } |