Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | DESCRIPTION = "Utilities to collect and visualise system statistics" |
| 2 | HOMEPAGE = "http://www.i-scream.org/libstatgrab/" |
| 3 | |
| 4 | LICENSE = "GPL-2.0+" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 6 | |
| 7 | DEPENDS = "ncurses" |
| 8 | |
| 9 | PACKAGES:prepend = "statgrab statgrab-dbg saidar saidar-dbg ${PN}-mrtg " |
| 10 | |
| 11 | # don't use the git tag unless docbooc2x is available to build the manpages |
| 12 | SRC_URI = "https://github.com/libstatgrab/libstatgrab/releases/download/LIBSTATGRAB_0_92_1/libstatgrab-${PV}.tar.gz \ |
| 13 | " |
| 14 | SRC_URI[sha256sum] = "5688aa4a685547d7174a8a373ea9d8ee927e766e3cc302bdee34523c2c5d6c11" |
| 15 | |
| 16 | UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/releases" |
| 17 | |
| 18 | # Perl5 is for tests only |
| 19 | EXTRA_OECONF = "--without-perl5 --with-mnttab=/proc/mounts" |
| 20 | |
| 21 | # use with caution - default properties are configured to trace |
| 22 | PACKAGECONFIG ??= "" |
| 23 | PACKAGECONFIG[log4cplus] = "--with-log4cplus,--without-log4cplus,log4cplus" |
| 24 | PACKAGECONFIG[logging] = "--enable-logging,--disable-logging," |
| 25 | |
| 26 | inherit autotools pkgconfig |
| 27 | |
| 28 | FILES:statgrab = "${bindir}/statgrab" |
| 29 | FILES:statgrab-dbg = "${bindir}/.debug/statgrab" |
| 30 | FILES:saidar = "${bindir}/saidar" |
| 31 | FILES:saidar-dbg = "${bindir}/.debug/saidar" |
| 32 | FILES:${PN}-mrtg = "${bindir}/statgrab-make-mrtg-config ${bindir}/statgrab-make-mrtg-index" |
| 33 | RDEPENDS:${PN}-mrtg:append = " perl statgrab" |