Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | DESCRIPTION = "A modern, C++-native, header-only, test framework for unit-tests, \ |
| 2 | TDD and BDD - using C++11, C++14, C++17 and later." |
| 3 | AUTHOR = "Phil Nash, Martin Horenovsky and others" |
| 4 | HOMEPAGE = "https://github.com/catchorg/Catch2" |
| 5 | LICENSE = "BSL-1.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c" |
| 7 | |
Andrew Geissler | 97771a3 | 2021-03-05 15:23:11 -0600 | [diff] [blame] | 8 | SRC_URI = "git://github.com/catchorg/Catch2.git;branch=v2.x" |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 9 | SRCREV = "5c88067bd339465513af4aec606bd2292f1b594a" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 10 | |
| 11 | S = "${WORKDIR}/git" |
| 12 | |
| 13 | inherit cmake python3native |
| 14 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 15 | do_install:append() { |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 16 | rm ${D}${datadir}/Catch2/lldbinit |
| 17 | rm ${D}${datadir}/Catch2/gdbinit |
| 18 | rmdir ${D}${datadir}/Catch2/ |
| 19 | } |
| 20 | # Header-only library |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 21 | RDEPENDS:${PN}-dev = "" |
| 22 | RRECOMMENDS:${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})" |