Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 1 | SUMMARY = "Perl interface to the libstatgrab library" |
| 2 | DESCRIPTION = "Unix::Statgrab is a wrapper for libstatgrab as available from \ |
| 3 | <http://www.i-scream.org/libstatgrab/>. It is a reasonably portable attempt \ |
| 4 | to query interesting stats about your computer. It covers information on \ |
| 5 | the operating system, CPU, memory usage, network interfaces, hard-disks \ |
| 6 | etc." |
| 7 | |
| 8 | HOMEPAGE = "https://metacpan.org/release/Unix-Statgrab" |
| 9 | SECTION = "libs" |
| 10 | LICENSE = "Artistic-1.0 | GPL-1.0+ | LGPL-2.1+" |
| 11 | DEPENDS += "libcapture-tiny-perl-native" |
| 12 | DEPENDS += "libconfig-autoconf-perl-native" |
| 13 | DEPENDS += "libstatgrab" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 14 | RDEPENDS:${PN} += "\ |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 15 | libstatgrab \ |
| 16 | perl-module-autoloader \ |
| 17 | perl-module-carp \ |
| 18 | perl-module-dynaloader \ |
| 19 | perl-module-exporter \ |
| 20 | perl-module-strict \ |
| 21 | perl-module-vars \ |
| 22 | perl-module-warnings \ |
| 23 | " |
| 24 | |
| 25 | SRC_URI = "${CPAN_MIRROR}/authors/id/R/RE/REHSACK/Unix-Statgrab-${PV}.tar.gz" |
| 26 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Artistic-1.0;md5=cda03bbdc3c1951996392b872397b798 \ |
Andrew Geissler | 97771a3 | 2021-03-05 15:23:11 -0600 | [diff] [blame] | 27 | file://${COMMON_LICENSE_DIR}/GPL-1.0-or-later;md5=30c0b8a5048cc2f4be5ff15ef0d8cf61 \ |
| 28 | file://${COMMON_LICENSE_DIR}/LGPL-2.1-or-later;md5=2a4f4fd2128ea2f65047ee63fbca9f68 \ |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 29 | " |
| 30 | |
| 31 | SRC_URI[md5sum] = "a6bc06b3f7749f7d77a2b1bd13402821" |
| 32 | SRC_URI[sha256sum] = "16a29f7acaeec081bf0e7303ba5ee24fda1d21a1104669b837745f3ea61d6afa" |
| 33 | |
| 34 | S = "${WORKDIR}/Unix-Statgrab-${PV}" |
| 35 | |
| 36 | inherit cpan pkgconfig ptest-perl |
| 37 | |
| 38 | BBCLASSEXTEND = "native" |