Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Incremental is a small library that versions your Python projects" |
| 2 | HOMEPAGE = "https://github.com/twisted/incremental" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=6ca9b07f08e2c72d48c74d363d1e0e15" |
| 5 | |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 6 | SRC_URI[sha256sum] = "02f5de5aff48f6b9f665d99d48bfc7ec03b6e3943210de7cfc88856d755d6f57" |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 7 | |
| 8 | inherit pypi setuptools3 |
| 9 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 10 | RDEPENDS:${PN} += " \ |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 11 | ${PYTHON_PN}-twisted \ |
| 12 | ${PYTHON_PN}-click \ |
| 13 | " |
| 14 | |
| 15 | # -native is needed to build python[3]-twisted, however, we need to take steps to |
| 16 | # prevent a circular dependency. The build apparently does not use the part of |
| 17 | # python-incremental which uses python-twisted, so this hack is OK. |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 18 | RDEPENDS:${PYTHON_PN}-incremental-native:remove = "${PYTHON_PN}-twisted-native" |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 19 | BBCLASSEXTEND = "native" |