Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Python WBEM Client and Provider Interface" |
| 2 | DESCRIPTION = "\ |
| 3 | A Python library for making CIM (Common Information Model) operations over \ |
| 4 | HTTP using the WBEM CIM-XML protocol. It is based on the idea that a good \ |
| 5 | WBEM client should be easy to use and not necessarily require a large amount \ |
| 6 | of programming knowledge. It is suitable for a large range of tasks from \ |
| 7 | simply poking around to writing web and GUI applications. \ |
| 8 | \ |
| 9 | WBEM, or Web Based Enterprise Management is a manageability protocol, like \ |
| 10 | SNMP, standardised by the Distributed Management Task Force (DMTF) available \ |
| 11 | at http://www.dmtf.org/standards/wbem. \ |
| 12 | \ |
| 13 | It also provides a Python provider interface, and is the fastest and easiest \ |
| 14 | way to write providers on the planet." |
| 15 | HOMEPAGE = "http://pywbem.github.io" |
| 16 | LICENSE = "LGPLv2.1" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 17 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fbc093901857fcd118f065f900982c24" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 18 | |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 19 | SRC_URI[sha256sum] = "8ef48185e0adbaeb9bd5181c4c5de951f6d58d54e2e1d7e87a9834e10eabe957" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 20 | |
Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 21 | inherit pypi setuptools3 update-alternatives |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 22 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 23 | DEPENDS += " \ |
| 24 | ${PYTHON_PN}-ply-native \ |
| 25 | ${PYTHON_PN}-pyyaml-native \ |
| 26 | ${PYTHON_PN}-six-native \ |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 27 | ${PYTHON_PN}-wheel-native \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 28 | " |
| 29 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 30 | RDEPENDS:${PN}:class-target += "\ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 31 | ${PYTHON_PN}-datetime \ |
| 32 | ${PYTHON_PN}-io \ |
| 33 | ${PYTHON_PN}-netclient \ |
| 34 | ${PYTHON_PN}-ply \ |
| 35 | ${PYTHON_PN}-pyyaml \ |
| 36 | ${PYTHON_PN}-six \ |
| 37 | ${PYTHON_PN}-stringold \ |
| 38 | ${PYTHON_PN}-threading \ |
| 39 | ${PYTHON_PN}-unixadmin \ |
| 40 | ${PYTHON_PN}-xml \ |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 41 | ${PYTHON_PN}-nocasedict \ |
| 42 | ${PYTHON_PN}-nocaselist \ |
| 43 | ${PYTHON_PN}-yamlloader \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 44 | " |
| 45 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 46 | ALTERNATIVE:${PN} = "mof_compiler" |
Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 47 | ALTERNATIVE_TARGET[mof_compiler] = "${bindir}/mof_compiler" |
Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 48 | |
| 49 | ALTERNATIVE_PRIORITY = "60" |
| 50 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 51 | BBCLASSEXTEND = "native" |