Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "WebKit web rendering engine for the GTK+ platform" |
| 2 | HOMEPAGE = "https://www.webkitgtk.org/" |
| 3 | BUGTRACKER = "https://bugs.webkit.org/" |
| 4 | |
| 5 | LICENSE = "BSD & LGPLv2+" |
| 6 | LIC_FILES_CHKSUM = "file://Source/JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d84286dda758da57bd691 \ |
| 7 | file://Source/WebCore/LICENSE-APPLE;md5=4646f90082c40bcf298c285f8bab0b12 \ |
| 8 | file://Source/WebCore/LICENSE-LGPL-2;md5=36357ffde2b64ae177b2494445b79d21 \ |
| 9 | file://Source/WebCore/LICENSE-LGPL-2.1;md5=a778a33ef338abbaf8b8a7c36b6eec80 \ |
| 10 | " |
| 11 | |
| 12 | SRC_URI = "https://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \ |
| 13 | file://0001-FindGObjectIntrospection.cmake-prefix-variables-obta.patch \ |
| 14 | file://0001-When-building-introspection-files-add-CMAKE_C_FLAGS-.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 15 | file://0001-Fix-racy-parallel-build-of-WebKit2-4.0.gir.patch \ |
| 16 | file://0001-Tweak-gtkdoc-settings-so-that-gtkdoc-generation-work.patch \ |
| 17 | file://0001-Enable-THREADS_PREFER_PTHREAD_FLAG.patch \ |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 18 | file://include_xutil.patch \ |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 19 | file://reduce-memory-overheads.patch \ |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 20 | file://musl-lower-stack-usage.patch \ |
Andrew Geissler | c926e17 | 2021-05-07 16:11:35 -0500 | [diff] [blame] | 21 | file://0001-MiniBrowser-Fix-reproduciblity.patch \ |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 22 | file://0001-Properly-use-CompletionHandler-when-USE_OPENGL_OR_ES.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 23 | " |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 24 | |
Andrew Geissler | 5f35090 | 2021-07-23 13:09:54 -0400 | [diff] [blame] | 25 | SRC_URI[sha256sum] = "1790f86975bdef957ba9a12fc09202de8f55c885ee38467afc50d2bdb7a6c5cd" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 26 | |
| 27 | inherit cmake pkgconfig gobject-introspection perlnative features_check upstream-version-is-even gtk-doc |
| 28 | |
| 29 | ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}" |
| 30 | REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'opengl', '', d)}" |
| 31 | |
| 32 | CVE_PRODUCT = "webkitgtk webkitgtk\+" |
| 33 | |
| 34 | DEPENDS = "zlib libsoup-2.4 curl libxml2 cairo libxslt libgcrypt \ |
| 35 | gtk+3 gstreamer1.0 gstreamer1.0-plugins-base flex-native gperf-native sqlite3 \ |
| 36 | pango icu bison-native gawk intltool-native libwebp \ |
| 37 | atk udev harfbuzz jpeg libpng librsvg libtheora libvorbis \ |
| 38 | ruby-native libnotify gstreamer1.0-plugins-bad \ |
| 39 | gettext-native glib-2.0 glib-2.0-native libtasn1 \ |
| 40 | " |
| 41 | |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 42 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd wayland x11', d)} \ |
Andrew Geissler | 1e34c2d | 2020-05-29 16:02:59 -0500 | [diff] [blame] | 43 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'webgl opengl', '', d)} \ |
| 44 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', 'webgl gles2', d)} \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 45 | enchant \ |
| 46 | libsecret \ |
| 47 | " |
| 48 | |
| 49 | PACKAGECONFIG[wayland] = "-DENABLE_WAYLAND_TARGET=ON,-DENABLE_WAYLAND_TARGET=OFF,wayland libwpe wpebackend-fdo wayland-native" |
| 50 | PACKAGECONFIG[x11] = "-DENABLE_X11_TARGET=ON,-DENABLE_X11_TARGET=OFF,virtual/libx11 libxcomposite libxdamage libxrender libxt" |
| 51 | PACKAGECONFIG[geoclue] = "-DENABLE_GEOLOCATION=ON,-DENABLE_GEOLOCATION=OFF,geoclue" |
| 52 | PACKAGECONFIG[enchant] = "-DENABLE_SPELLCHECK=ON,-DENABLE_SPELLCHECK=OFF,enchant2" |
| 53 | PACKAGECONFIG[gles2] = "-DENABLE_GLES2=ON,-DENABLE_GLES2=OFF,virtual/libgles2" |
| 54 | PACKAGECONFIG[webgl] = "-DENABLE_WEBGL=ON,-DENABLE_WEBGL=OFF,virtual/libgl" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 55 | PACKAGECONFIG[opengl] = "-DENABLE_GRAPHICS_CONTEXT_GL=ON,-DENABLE_GRAPHICS_CONTEXT_GL=OFF,virtual/libgl" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 56 | PACKAGECONFIG[libsecret] = "-DUSE_LIBSECRET=ON,-DUSE_LIBSECRET=OFF,libsecret" |
| 57 | PACKAGECONFIG[libhyphen] = "-DUSE_LIBHYPHEN=ON,-DUSE_LIBHYPHEN=OFF,libhyphen" |
| 58 | PACKAGECONFIG[woff2] = "-DUSE_WOFF2=ON,-DUSE_WOFF2=OFF,woff2" |
| 59 | PACKAGECONFIG[openjpeg] = "-DUSE_OPENJPEG=ON,-DUSE_OPENJPEG=OFF,openjpeg" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 60 | PACKAGECONFIG[systemd] = "-DUSE_SYSTEMD=ON,-DUSE_SYSTEMD=off,systemd" |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 61 | PACKAGECONFIG[reduce-size] = "-DCMAKE_BUILD_TYPE=MinSizeRel,-DCMAKE_BUILD_TYPE=Release,," |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 62 | |
| 63 | # webkitgtk is full of /usr/bin/env python, particular for generating docs |
| 64 | do_configure[postfuncs] += "setup_python_link" |
| 65 | setup_python_link() { |
| 66 | if [ ! -e ${STAGING_BINDIR_NATIVE}/python ]; then |
| 67 | ln -s `which python3` ${STAGING_BINDIR_NATIVE}/python |
| 68 | fi |
| 69 | } |
| 70 | |
| 71 | EXTRA_OECMAKE = " \ |
| 72 | -DPORT=GTK \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 73 | ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_INTROSPECTION=ON', '-DENABLE_INTROSPECTION=OFF', d)} \ |
| 74 | ${@bb.utils.contains('GTKDOC_ENABLED', 'True', '-DENABLE_GTKDOC=ON', '-DENABLE_GTKDOC=OFF', d)} \ |
| 75 | -DENABLE_MINIBROWSER=ON \ |
| 76 | -DPYTHON_EXECUTABLE=`which python3` \ |
| 77 | -DENABLE_BUBBLEWRAP_SANDBOX=OFF \ |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 78 | -DENABLE_GAMEPAD=OFF \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 79 | " |
| 80 | |
| 81 | # Javascript JIT is not supported on ARC |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 82 | EXTRA_OECMAKE:append:arc = " -DENABLE_JIT=OFF " |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 83 | # By default 25-bit "medium" calls are used on ARC |
| 84 | # which is not enough for binaries larger than 32 MiB |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 85 | CFLAGS:append:arc = " -mlong-calls" |
| 86 | CXXFLAGS:append:arc = " -mlong-calls" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 87 | |
| 88 | # Javascript JIT is not supported on powerpc |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 89 | EXTRA_OECMAKE:append:powerpc = " -DENABLE_JIT=OFF " |
| 90 | EXTRA_OECMAKE:append:powerpc64 = " -DENABLE_JIT=OFF " |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 91 | |
| 92 | # ARM JIT code does not build on ARMv4/5/6 anymore |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 93 | EXTRA_OECMAKE:append:armv5 = " -DENABLE_JIT=OFF " |
| 94 | EXTRA_OECMAKE:append:armv6 = " -DENABLE_JIT=OFF " |
| 95 | EXTRA_OECMAKE:append:armv4 = " -DENABLE_JIT=OFF " |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 96 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 97 | EXTRA_OECMAKE:append:mipsarch = " -DUSE_LD_GOLD=OFF " |
| 98 | EXTRA_OECMAKE:append:powerpc = " -DUSE_LD_GOLD=OFF " |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 99 | |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 100 | # JIT and gold linker does not work on RISCV |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 101 | EXTRA_OECMAKE:append:riscv32 = " -DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF" |
| 102 | EXTRA_OECMAKE:append:riscv64 = " -DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 103 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 104 | # JIT not supported on MIPS either |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 105 | EXTRA_OECMAKE:append:mipsarch = " -DENABLE_JIT=OFF -DENABLE_C_LOOP=ON " |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 106 | |
| 107 | # JIT not supported on X32 |
| 108 | # An attempt was made to upstream JIT support for x32 in |
| 109 | # https://bugs.webkit.org/show_bug.cgi?id=100450, but this was closed as |
| 110 | # unresolved due to limited X32 adoption. |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 111 | EXTRA_OECMAKE:append:x86-x32 = " -DENABLE_JIT=OFF " |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 112 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 113 | SECURITY_CFLAGS:remove:aarch64 = "-fpie" |
| 114 | SECURITY_CFLAGS:append:aarch64 = " -fPIE" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 115 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 116 | FILES:${PN} += "${libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 117 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 118 | RRECOMMENDS:${PN} += "ca-certificates shared-mime-info" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 119 | |
| 120 | # http://errors.yoctoproject.org/Errors/Details/20370/ |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 121 | ARM_INSTRUCTION_SET:armv4 = "arm" |
| 122 | ARM_INSTRUCTION_SET:armv5 = "arm" |
| 123 | ARM_INSTRUCTION_SET:armv6 = "arm" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 124 | |
| 125 | # https://bugzilla.yoctoproject.org/show_bug.cgi?id=9474 |
| 126 | # https://bugs.webkit.org/show_bug.cgi?id=159880 |
| 127 | # JSC JIT can build on ARMv7 with -marm, but doesn't work on runtime. |
| 128 | # Upstream only tests regularly the JSC JIT on ARMv7 with Thumb2 (-mthumb). |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 129 | ARM_INSTRUCTION_SET:armv7a = "thumb" |
| 130 | ARM_INSTRUCTION_SET:armv7r = "thumb" |
| 131 | ARM_INSTRUCTION_SET:armv7ve = "thumb" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 132 | |
| 133 | # introspection inside qemu-arm hangs forever on musl/arm builds |
| 134 | # therefore disable GI_DATA |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 135 | GI_DATA_ENABLED:libc-musl:armv7a = "False" |
| 136 | GI_DATA_ENABLED:libc-musl:armv7ve = "False" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 137 | |
| 138 | # Can't be built with ccache |
| 139 | CCACHE_DISABLE = "1" |
Andrew Geissler | 09209ee | 2020-12-13 08:44:15 -0600 | [diff] [blame] | 140 | |
| 141 | PACKAGE_PREPROCESS_FUNCS += "src_package_preprocess" |
| 142 | src_package_preprocess () { |
| 143 | # Trim build paths from comments in generated sources to ensure reproducibility |
| 144 | sed -i -e "s,${WORKDIR},,g" \ |
| 145 | ${B}/DerivedSources/webkit2gtk/webkit2/*.cpp \ |
| 146 | ${B}/DerivedSources/ForwardingHeaders/JavaScriptCore/*.h \ |
| 147 | ${B}/DerivedSources/JavaScriptCore/*.h \ |
| 148 | ${B}/DerivedSources/JavaScriptCore/yarr/*.h \ |
| 149 | ${B}/DerivedSources/MiniBrowser/*.c |
| 150 | } |
| 151 | |