Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "Intel(R) Enclosure LED Utilities" |
| 2 | |
| 3 | DESCRIPTION = "The utilities are designed primarily to be used on storage servers \ |
| 4 | utilizing MD devices (aka Linux Software RAID) for RAID arrays.\ |
| 5 | " |
| 6 | HOMEPAGE = "https://github.com/intel/ledmon" |
| 7 | |
| 8 | LICENSE = "GPLv2" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \ |
| 10 | " |
| 11 | |
| 12 | DEPENDS = "sg3-utils udev" |
| 13 | |
Brad Bishop | 868407c | 2019-11-04 13:24:47 -0500 | [diff] [blame] | 14 | inherit autotools systemd |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 15 | |
| 16 | SYSTEMD_SERVICE_${PN} = "ledmon.service" |
| 17 | |
Brad Bishop | 868407c | 2019-11-04 13:24:47 -0500 | [diff] [blame] | 18 | # 0.93 |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 19 | SRC_URI = "git://github.com/intel/ledmon;branch=master \ |
| 20 | file://0002-include-sys-select.h-and-sys-types.h.patch \ |
Brad Bishop | 868407c | 2019-11-04 13:24:47 -0500 | [diff] [blame] | 21 | file://0001-Don-t-build-with-Werror-to-fix-compile-error.patch \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 22 | " |
| 23 | |
Brad Bishop | 868407c | 2019-11-04 13:24:47 -0500 | [diff] [blame] | 24 | SRCREV = "1d72f9cb5c9163b2ecdf19709935720e65f5b90e" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 25 | |
| 26 | COMPATIBLE_HOST = "(i.86|x86_64).*-linux" |
| 27 | COMPATIBLE_HOST_libc-musl = "null" |
| 28 | |
| 29 | S = "${WORKDIR}/git" |
| 30 | EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}' CFLAGS='${CFLAGS}'" |
| 31 | |
Brad Bishop | 868407c | 2019-11-04 13:24:47 -0500 | [diff] [blame] | 32 | # The ledmon sources include headers in ${S}/config to build but not in CFLAGS. |
| 33 | # We need to add this include path in CFLAGS. |
| 34 | CFLAGS += "-I${S}/config" |
| 35 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 36 | do_install_append() { |
Brad Bishop | 868407c | 2019-11-04 13:24:47 -0500 | [diff] [blame] | 37 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then |
| 38 | install -d ${D}${systemd_unitdir}/system |
| 39 | install -m 0755 ${S}/systemd/ledmon.service ${D}${systemd_unitdir}/system |
| 40 | fi |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 41 | } |