Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 1 | SUMMARY = "Capture::Tiny - Capture STDOUT and STDERR from Perl, XS or external programs." |
| 2 | DESCRIPTION = "Capture::Tiny provies a simple, portable way to capture \ |
| 3 | almost anything sent to STDOUT or STDERR, regardless of whether it comes \ |
| 4 | from Perl, from XS code or from an external program. Optionally, output can \ |
| 5 | be teed so that it is captured while being passed through to the original \ |
| 6 | filehandles. Yes, it even works on Windows (usually). Stop guessing which of \ |
| 7 | a dozen capturing modules to use in any particular situation and just use \ |
| 8 | this one." |
| 9 | SECTION = "libs" |
| 10 | |
| 11 | HOMEPAGE = "http://search.cpan.org/~dagolden/Capture-Tiny/" |
| 12 | |
| 13 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 14 | LIC_FILES_CHKSUM = "file://LICENSE;md5=37a4918a30ace24395020e5b8c03b83f" |
| 15 | |
| 16 | SRCNAME = "Capture-Tiny" |
| 17 | SRC_URI = "${CPAN_MIRROR}/authors/id/D/DA/DAGOLDEN/${SRCNAME}-${PV}.tar.gz" |
| 18 | SRC_URI[md5sum] = "f5d24083ad270f8326dd659dd83eeb54" |
| 19 | SRC_URI[sha256sum] = "6c23113e87bad393308c90a207013e505f659274736638d8c79bac9c67cc3e19" |
| 20 | |
| 21 | S = "${WORKDIR}/${SRCNAME}-${PV}" |
| 22 | |
| 23 | inherit cpan ptest-perl |
| 24 | |
| 25 | RDEPENDS_${PN} = " \ |
| 26 | perl-module-carp \ |
| 27 | perl-module-exporter \ |
| 28 | perl-module-extutils-makemaker \ |
| 29 | perl-module-extutils-mm-unix \ |
| 30 | perl-module-file-spec \ |
| 31 | perl-module-file-temp \ |
| 32 | perl-module-io-handle \ |
| 33 | perl-module-lib \ |
| 34 | perl-module-overloading \ |
| 35 | perl-module-perlio \ |
| 36 | perl-module-perlio-scalar \ |
| 37 | perl-module-scalar-util \ |
| 38 | perl-module-strict \ |
| 39 | perl-module-test-more \ |
| 40 | perl-module-warnings \ |
| 41 | " |
| 42 | |
| 43 | RDEPENDS_${PN}-ptest += "perl-module-perlio" |
| 44 | |
| 45 | BBCLASSEXTEND = "native" |