Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 1 | SUMMARY = "Make sure you didn't emit any warnings while testing" |
| 2 | DESCRIPTION = "In general, your tests shouldn't produce warnings. This \ |
| 3 | modules causes any warnings to be captured and stored. It automatically \ |
| 4 | adds an extra test that will run when your script ends to check that there \ |
| 5 | were no warnings. If there were any warings, the test will give a \\"not ok\\" \ |
| 6 | and diagnostics of where, when and what the warning was, including a stack \ |
| 7 | trace of what was going on when the it occurred.\ |
| 8 | \ |
| 9 | If some of your tests are supposed to produce warnings then you should \ |
| 10 | be capturing and checking them with Test::Warn, that way \ |
| 11 | Test::NoWarnings will not see them and so not complain.\ |
| 12 | \ |
| 13 | The test is run by an \\"END\\" block in Test::NoWarnings. It will not be \ |
| 14 | run when any forked children exit." |
| 15 | |
| 16 | SECTION = "libs" |
| 17 | LICENSE = "LGPL-2.1" |
| 18 | |
| 19 | HOMEPAGE= "https://metacpan.org/release/Test-NoWarnings" |
| 20 | |
| 21 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d8045f3b8f929c1cb29a1e3fd737b499" |
| 22 | |
| 23 | CPAN_PACKAGE = "Test-NoWarnings" |
| 24 | CPAN_AUTHOR = "ADAMK" |
| 25 | |
| 26 | SRC_URI = "${CPAN_MIRROR}/authors/id/A/AD/${CPAN_AUTHOR}/${CPAN_PACKAGE}-${PV}.tar.gz" |
| 27 | |
| 28 | SRC_URI[md5sum] = "682ed043f7d3e38f3dfd8745fd21c49a" |
| 29 | SRC_URI[sha256sum] = "638a57658cb119af1fe5b15e73d47c2544dcfef84af0c6b1b2e97f08202b686c" |
| 30 | |
| 31 | RDEPENDS_${PN} += "perl-module-test-builder perl-module-test-more perl-module-test-tester" |
| 32 | |
| 33 | S = "${WORKDIR}/${CPAN_PACKAGE}-${PV}" |
| 34 | |
| 35 | inherit cpan ptest-perl |
| 36 | |
| 37 | BBCLASSEXTEND = "native nativesdk" |