blob: 6a02df48544c7a34cd40c9486b35acc30a5264cf [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "General-purpose x86 assembler"
2SECTION = "devel"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=90904486f8fbf1861cf42752e1a39efe"
5
6SRC_URI = "http://www.nasm.us/pub/nasm/releasebuilds/${PV}/nasm-${PV}.tar.bz2 \
7 file://0001-asmlib-Drop-pure-function-attribute-from-seg_init.patch \
Brad Bishop220d5532018-08-14 00:59:39 +01008 file://0001-assemble-Check-global-line-limit.patch \
9 file://0001-fix-CVE-2018-8882.patch \
10 file://0001-Verify-that-we-are-not-reading-past-end-of-a-buffer.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -040011 "
12
13SRC_URI[md5sum] = "0c581d482f39d5111879ca9601938f74"
14SRC_URI[sha256sum] = "63ec86477ad3f0f6292325fd89e1d93aea2e2fd490070863f17d48f7cd387011"
15
16inherit autotools-brokensep
17
18do_configure_prepend () {
19 if [ -f ${S}/aclocal.m4 ] && [ ! -f ${S}/acinclude.m4 ]; then
20 mv ${S}/aclocal.m4 ${S}/acinclude.m4
21 fi
22}
23
24do_install() {
25 install -d ${D}${bindir}
26 install -d ${D}${mandir}/man1
27
28 oe_runmake 'INSTALLROOT=${D}' install
29}
30
31BBCLASSEXTEND = "native"
32
33DEPENDS = "groff-native"