Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "Portable C library for multiline text editing" |
| 2 | HOMEPAGE = "http://projects.gnome.org/gtksourceview/" |
| 3 | |
| 4 | LICENSE = "LGPLv2.1" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24" |
| 6 | |
| 7 | DEPENDS = "gtk+3 libxml2 intltool-native gnome-common-native glib-2.0-native" |
| 8 | |
| 9 | PNAME = "gtksourceview" |
| 10 | |
| 11 | S = "${WORKDIR}/${PNAME}-${PV}" |
| 12 | |
Brad Bishop | 93c3acf | 2019-10-29 09:48:15 -0400 | [diff] [blame] | 13 | GNOMEBASEBUILDCLASS = "meson" |
| 14 | |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 15 | inherit gnomebase lib_package gettext features_check gtk-doc gobject-introspection vala |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 16 | |
| 17 | REQUIRED_DISTRO_FEATURES = "x11" |
| 18 | |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 19 | SRC_URI = "https://download.gnome.org/sources/gtksourceview/4.8/${PNAME}-${PV}.tar.xz" |
| 20 | SRC_URI[sha256sum] = "d163d71b5fcafbc5b1eec6dd841edbdbcddd3a7511cd5fdcffd86b8bbfe69ac1" |
Brad Bishop | 93c3acf | 2019-10-29 09:48:15 -0400 | [diff] [blame] | 21 | |
| 22 | GIR_MESON_OPTION = 'gir' |
| 23 | GTKDOC_MESON_OPTION = "gtk_doc" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 24 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 25 | # Override the definition in meson.bbclass. The dependencies in mason.build are incomplete |
| 26 | # and the recipe will not build with "-j 1". This fix is benign but should be reviewed when |
| 27 | # updating versions. |
| 28 | # |
| 29 | meson_do_compile() { |
| 30 | bbnote "========== generating gtksourceview-gresources.h ========" |
| 31 | bbnote "PARALLEL_MAKE is ${PARALLEL_MAKE}" |
| 32 | ninja ${PARALLEL_MAKE} gtksourceview/gtksourceview-gresources.h |
| 33 | bbnote "========== compiling target all ========" |
| 34 | ninja ${PARALLEL_MAKE} |
| 35 | } |
| 36 | |
| 37 | FILES:${PN} += "${datadir}/gtksourceview-4" |