Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Wireless Central Regulatory Domain Agent" |
| 2 | HOMEPAGE = "http://wireless.kernel.org/en/developers/Regulatory/CRDA" |
| 3 | SECTION = "net" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 4 | LICENSE = "copyleft-next-0.3.0" |
| 5 | LIC_FILES_CHKSUM = "file://copyleft-next-0.3.0;md5=8743a2c359037d4d329a31e79eabeffe" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 6 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 7 | DEPENDS = "python3-m2crypto-native libnl libgcrypt" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 8 | |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 9 | SRC_URI = "https://www.kernel.org/pub/software/network/${BPN}/${BP}.tar.xz \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 10 | file://do-not-run-ldconfig-if-destdir-is-set.patch \ |
| 11 | file://fix-linking-of-libraries-used-by-reglib.patch \ |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 12 | file://fix-gcc-6-unused-variables.patch \ |
| 13 | file://0001-Makefile-respect-LDFLAGS-for-libreg.patch \ |
Brad Bishop | 7f28bc5 | 2017-12-03 23:42:40 -0500 | [diff] [blame] | 14 | file://make.patch \ |
| 15 | file://use-target-word-size-instead-of-host-s.patch \ |
| 16 | file://fix-issues-when-USE_OPENSSL-1.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 17 | file://crda-4.14-python-3.patch \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 18 | " |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 19 | SRC_URI[md5sum] = "0431fef3067bf503dfb464069f06163a" |
| 20 | SRC_URI[sha256sum] = "43fcb9679f8b75ed87ad10944a506292def13e4afb194afa7aa921b01e8ecdbf" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 21 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 22 | inherit python3-dir python3native siteinfo |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 23 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 24 | # Recursive make problem |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 25 | EXTRA_OEMAKE = "MAKEFLAGS= DESTDIR=${D} LIBDIR=${libdir}/crda LDLIBREG='-Wl,-rpath,${libdir}/crda -lreg' \ |
Brad Bishop | 0e2770c | 2020-01-21 07:31:46 -0500 | [diff] [blame] | 26 | UDEV_RULE_DIR=${nonarch_base_libdir}/udev/rules.d/" |
Brad Bishop | 7f28bc5 | 2017-12-03 23:42:40 -0500 | [diff] [blame] | 27 | TARGET_BITS = "${SITEINFO_BITS}" |
| 28 | export TARGET_BITS |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 29 | |
| 30 | do_compile() { |
| 31 | oe_runmake all_noverify |
| 32 | } |
| 33 | |
| 34 | do_install() { |
| 35 | oe_runmake SBINDIR=${sbindir}/ install |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 36 | } |
| 37 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 38 | RDEPENDS:${PN} = "udev wireless-regdb-static" |