Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 1 | SUMMARY = "Xilinx Platform Headers" |
| 2 | DESCRPTION = "Xilinx ps*_init_gpl.c/h platform init code, used for building u-boot-spl and fsbl" |
| 3 | HOMEPAGE = "http://www.xilinx.com" |
| 4 | SECTION = "bsp" |
| 5 | |
| 6 | INHIBIT_DEFAULT_DEPS = "1" |
| 7 | |
| 8 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 9 | |
| 10 | inherit xilinx-platform-init |
| 11 | |
| 12 | COMPATIBLE_MACHINE = "$^" |
| 13 | COMPATIBLE_MACHINE_picozed-zynq7 = "picozed-zynq7" |
| 14 | |
| 15 | LICENSE = "GPLv2+" |
| 16 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" |
| 17 | |
| 18 | PROVIDES += "virtual/xilinx-platform-init" |
| 19 | |
| 20 | SRC_URI = "${@" ".join(["file://%s" % f for f in (d.getVar('PLATFORM_INIT_FILES') or "").split()])}" |
| 21 | |
| 22 | S = "${WORKDIR}" |
| 23 | |
| 24 | SYSROOT_DIRS += "${PLATFORM_INIT_DIR}" |
| 25 | |
| 26 | do_compile() { |
| 27 | : |
| 28 | } |
| 29 | |
| 30 | do_install() { |
| 31 | install -d ${D}${PLATFORM_INIT_DIR} |
| 32 | for i in ${PLATFORM_INIT_FILES}; do |
| 33 | install -m 0644 ${S}/$i ${D}${PLATFORM_INIT_DIR}/ |
| 34 | done |
| 35 | } |
| 36 | |
| 37 | FILES_${PN} += "${PLATFORM_INIT_DIR}/*" |
| 38 | |