Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Host side USB console utilities" |
| 2 | DESCRIPTION = "Contains the lsusb utility for inspecting the devices connected to the USB bus." |
| 3 | HOMEPAGE = "http://www.linux-usb.org" |
| 4 | SECTION = "base" |
| 5 | |
| 6 | LICENSE = "GPLv2+" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 8 | |
| 9 | DEPENDS = "libusb zlib virtual/libiconv udev" |
| 10 | |
| 11 | SRC_URI = "${KERNELORG_MIRROR}/linux/utils/usb/usbutils/usbutils-${PV}.tar.gz \ |
| 12 | file://usb-devices-avoid-dependency-on-bash.patch \ |
| 13 | " |
| 14 | |
| 15 | SRC_URI[md5sum] = "b5dbc498b2eb5058f7a57fc6532d0aad" |
| 16 | SRC_URI[sha256sum] = "e73543293a17c7803994eac97a49e58b377e08e6299ba11aad09794b91340e8b" |
| 17 | |
| 18 | inherit autotools pkgconfig distro_features_check update-alternatives |
| 19 | |
| 20 | ALTERNATIVE_${PN} = "lsusb" |
| 21 | ALTERNATIVE_PRIORITY = "100" |
| 22 | |
| 23 | FILES_${PN}-dev += "${datadir}/pkgconfig" |
| 24 | |
| 25 | RRECOMMENDS_${PN} = "udev-hwdb" |
| 26 | RDEPENDS_${PN}-ptest = "libboost-system libboost-thread" |
| 27 | |
| 28 | PACKAGE_BEFORE_PN =+ "${PN}-python" |
| 29 | FILES_${PN}-python += "${bindir}/lsusb.py" |
| 30 | RDEPENDS_${PN}-python = "python3-core" |
| 31 | |
| 32 | do_install_append() { |
| 33 | sed -i -E '1s,#!.+python,#!${bindir}/python3,' ${D}${bindir}/lsusb.py |
| 34 | } |