Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Backup, restore, import, and export panel layouts" |
| 2 | SECTION = "x11/application" |
| 3 | LICENSE = "GPLv3" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 5 | |
| 6 | inherit python3native gettext distro_features_check |
| 7 | |
| 8 | REQUIRED_DISTRO_FEATURES = "x11" |
| 9 | |
| 10 | DEPENDS += "intltool-native" |
| 11 | |
| 12 | SRC_URI = "http://archive.xfce.org/src/apps/${BPN}/1.0/${BPN}-${PV}.tar.bz2" |
| 13 | SRC_URI[md5sum] = "bc75a143423fba3a82f114f47e86580c" |
| 14 | SRC_URI[sha256sum] = "a69e20f5e637319e14898b5c13ff7ba31d001a6e38e7516d70dbfd7600ad72db" |
| 15 | |
| 16 | do_configure() { |
| 17 | # special configure - no autotools... |
| 18 | ./configure --prefix=${prefix} |
| 19 | } |
| 20 | |
| 21 | do_install() { |
| 22 | oe_runmake 'DESTDIR=${D}' install |
| 23 | sed -i 's:${PYTHON}:python3:g' ${D}${bindir}/xfce4-panel-profiles |
| 24 | } |
| 25 | |
| 26 | FILES_${PN} += "${datadir}/metainfo" |
| 27 | |
| 28 | RDEPENDS_${PN} += "python3-pygobject python3-pexpect" |