Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 1 | DESCRIPTION = "Security packagegroup for Poky" |
| 2 | LICENSE = "MIT" |
| 3 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302 \ |
| 4 | file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" |
| 5 | |
| 6 | inherit packagegroup |
| 7 | |
| 8 | PACKAGES = "\ |
| 9 | packagegroup-core-security \ |
| 10 | packagegroup-security-utils \ |
| 11 | packagegroup-security-scanners \ |
| 12 | packagegroup-security-ids \ |
| 13 | packagegroup-security-mac \ |
| 14 | ${@bb.utils.contains("MACHINE_FEATURES", "tpm", "packagegroup-security-tpm", "",d)} \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 15 | ${@bb.utils.contains("DISTRO_FEATURES", "ptest", "packagegroup-security-ptest", "", d)} \ |
Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 16 | " |
| 17 | |
| 18 | RDEPENDS_packagegroup-core-security = "\ |
| 19 | packagegroup-security-utils \ |
| 20 | packagegroup-security-scanners \ |
| 21 | packagegroup-security-ids \ |
| 22 | packagegroup-security-mac \ |
| 23 | ${@bb.utils.contains("MACHINE_FEATURES", "tpm", "packagegroup-security-tpm", "",d)} \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 24 | ${@bb.utils.contains("DISTRO_FEATURES", "ptest", "packagegroup-security-ptest", "", d)} \ |
Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 25 | " |
| 26 | |
| 27 | SUMMARY_packagegroup-security-utils = "Security utilities" |
| 28 | RDEPENDS_packagegroup-security-utils = "\ |
| 29 | checksec \ |
| 30 | nmap \ |
| 31 | pinentry \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 32 | python-scapy \ |
| 33 | ding-libs \ |
| 34 | xmlsec1 \ |
| 35 | keyutils \ |
| 36 | libseccomp \ |
Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 37 | ${@bb.utils.contains("DISTRO_FEATURES", "pax", "pax-utils", "",d)} \ |
| 38 | " |
| 39 | |
| 40 | SUMMARY_packagegroup-security-scanners = "Security scanners" |
| 41 | RDEPENDS_packagegroup-security-scanners = "\ |
| 42 | nikto \ |
| 43 | checksecurity \ |
| 44 | clamav \ |
| 45 | " |
| 46 | |
| 47 | SUMMARY_packagegroup-security-audit = "Security Audit tools " |
| 48 | RDEPENDS_packagegroup-security-audit = " \ |
| 49 | buck-security \ |
| 50 | redhat-security \ |
| 51 | " |
| 52 | |
| 53 | SUMMARY_packagegroup-security-hardening = "Security Hardening tools" |
| 54 | RDEPENDS_packagegroup-security-hardening = " \ |
| 55 | bastille \ |
| 56 | " |
| 57 | |
| 58 | SUMMARY_packagegroup-security-ids = "Security Intrusion Detection systems" |
| 59 | RDEPENDS_packagegroup-security-ids = " \ |
| 60 | tripwire \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 61 | samhain-standalone \ |
Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 62 | suricata \ |
| 63 | " |
| 64 | |
| 65 | SUMMARY_packagegroup-security-mac = "Security Mandatory Access Control systems" |
| 66 | RDEPENDS_packagegroup-security-mac = " \ |
| 67 | ${@bb.utils.contains("DISTRO_FEATURES", "tomoyo", "ccs-tools", "",d)} \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 68 | ${@bb.utils.contains("DISTRO_FEATURES", "apparmor", "apparmor", "",d)} \ |
Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 69 | ${@bb.utils.contains("DISTRO_FEATURES", "smack", "smack", "",d)} \ |
| 70 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 71 | |
| 72 | SUMMARY_packagegroup-security-ptest = "Security packages with ptests" |
| 73 | RDEPENDS_packagegroup-security-ptest = " \ |
| 74 | samhain-standalone-ptest \ |
| 75 | xmlsec1-ptest \ |
| 76 | keyutils-ptest \ |
| 77 | libseccomp-ptest \ |
| 78 | python-scapy-ptest \ |
| 79 | suricata-ptest \ |
| 80 | tripwire-ptest \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 81 | python-fail2ban-ptest \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 82 | ${@bb.utils.contains("DISTRO_FEATURES", "apparmor", "apparmor-ptest", "",d)} \ |
| 83 | ${@bb.utils.contains("DISTRO_FEATURES", "smack", "smack-ptest", "",d)} \ |
| 84 | ptest-runner \ |
| 85 | " |