Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "gnu-configize" |
| 2 | DESCRIPTION = "Tool that installs the GNU config.guess / config.sub into a directory tree" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 3 | HOMEPAGE = "https://git.savannah.gnu.org/cgit/config.git" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 4 | SECTION = "devel" |
| 5 | LICENSE = "GPL-3.0-with-autoconf-exception" |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://config.guess;beginline=9;endline=29;md5=10922f9231863a06f6efb67691fa46e0" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 7 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 8 | DEPENDS:class-native = "hostperl-runtime-native" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 9 | |
| 10 | INHIBIT_DEFAULT_DEPS = "1" |
| 11 | |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 12 | SRCREV = "02ba26b218d3d3db6c56e014655faf463cefa983" |
| 13 | PV = "20220525+git${SRCPV}" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 14 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 15 | SRC_URI = "git://git.savannah.gnu.org/git/config.git;protocol=https;branch=master \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 16 | file://gnu-configize.in" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 17 | S = "${WORKDIR}/git" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 18 | UPSTREAM_CHECK_COMMITS = "1" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 19 | |
| 20 | CLEANBROKEN = "1" |
| 21 | |
| 22 | do_compile[noexec] = "1" |
| 23 | |
| 24 | do_install () { |
| 25 | install -d ${D}${datadir}/gnu-config \ |
| 26 | ${D}${bindir} |
| 27 | cat ${WORKDIR}/gnu-configize.in | \ |
| 28 | sed -e 's,@gnu-configdir@,${datadir}/gnu-config,g' \ |
| 29 | -e 's,@autom4te_perllibdir@,${datadir}/autoconf,g' > ${D}${bindir}/gnu-configize |
| 30 | # In the native case we want the system perl as perl-native can't have built yet |
| 31 | if [ "${PN}" != "gnu-config-native" -a "${PN}" != "nativesdk-gnu-config" ]; then |
| 32 | sed -i -e 's,/usr/bin/env,${bindir}/env,g' ${D}${bindir}/gnu-configize |
| 33 | fi |
| 34 | chmod 755 ${D}${bindir}/gnu-configize |
| 35 | install -m 0644 config.guess config.sub ${D}${datadir}/gnu-config/ |
| 36 | } |
| 37 | |
| 38 | PACKAGES = "${PN}" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 39 | FILES:${PN} = "${bindir} ${datadir}/gnu-config" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 40 | |
| 41 | BBCLASSEXTEND = "native nativesdk" |