Andrew Geissler | c926e17 | 2021-05-07 16:11:35 -0500 | [diff] [blame] | 1 | SUMMARY = "interface to seccomp filtering mechanism" |
| 2 | DESCRIPTION = "The libseccomp library provides and easy to use, platform independent,interface to the Linux Kernel's syscall filtering mechanism: seccomp." |
| 3 | HOMEPAGE = "https://github.com/seccomp/libseccomp" |
| 4 | SECTION = "security" |
| 5 | LICENSE = "LGPL-2.1" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;beginline=0;endline=1;md5=8eac08d22113880357ceb8e7c37f989f" |
| 7 | |
| 8 | DEPENDS += "gperf-native" |
| 9 | |
Andrew Geissler | 5f35090 | 2021-07-23 13:09:54 -0400 | [diff] [blame] | 10 | PV .= "+git${SRCPV}" |
| 11 | SRCREV = "5822e50c2920ce597d038077dea4a0eedf193f86" |
Andrew Geissler | c926e17 | 2021-05-07 16:11:35 -0500 | [diff] [blame] | 12 | |
Andrew Geissler | 5f35090 | 2021-07-23 13:09:54 -0400 | [diff] [blame] | 13 | SRC_URI = "git://github.com/seccomp/libseccomp.git;branch=main \ |
| 14 | file://0001-configure.ac-Bump-version-to-2.5.99.patch \ |
| 15 | file://0001-arch-Add-riscv32-architecture-support.patch \ |
| 16 | file://0002-Regenerate-syscall-cvs-file-from-5.13-rc5-kernel.patch \ |
Andrew Geissler | c926e17 | 2021-05-07 16:11:35 -0500 | [diff] [blame] | 17 | file://run-ptest \ |
| 18 | " |
| 19 | |
Andrew Geissler | c926e17 | 2021-05-07 16:11:35 -0500 | [diff] [blame] | 20 | S = "${WORKDIR}/git" |
| 21 | |
| 22 | inherit autotools-brokensep pkgconfig ptest features_check |
| 23 | |
| 24 | REQUIRED_DISTRO_FEATURES = "seccomp" |
| 25 | |
| 26 | PACKAGECONFIG ??= "" |
| 27 | PACKAGECONFIG[python] = "--enable-python, --disable-python, python3" |
| 28 | |
| 29 | DISABLE_STATIC = "" |
| 30 | |
| 31 | do_compile_ptest() { |
| 32 | oe_runmake -C tests check-build |
| 33 | } |
| 34 | |
| 35 | do_install_ptest() { |
| 36 | install -d ${D}${PTEST_PATH}/tests |
| 37 | install -d ${D}${PTEST_PATH}/tools |
| 38 | for file in $(find tests/* -executable -type f); do |
| 39 | install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests |
| 40 | done |
| 41 | for file in $(find tests/*.tests -type f); do |
| 42 | install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests |
| 43 | done |
| 44 | for file in $(find tools/* -executable -type f); do |
| 45 | install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools |
| 46 | done |
| 47 | # Overwrite libtool wrappers with real executables |
| 48 | for file in $(find tools/.libs/* -executable -type f); do |
| 49 | install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools |
| 50 | done |
| 51 | } |
| 52 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 53 | FILES:${PN} = "${bindir} ${libdir}/${BPN}.so*" |
| 54 | FILES:${PN}-dbg += "${libdir}/${PN}/tests/.debug/* ${libdir}/${PN}/tools/.debug" |
Andrew Geissler | c926e17 | 2021-05-07 16:11:35 -0500 | [diff] [blame] | 55 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 56 | RDEPENDS:${PN}-ptest = "coreutils bash" |