Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | SUMMARY = "A self-extracting archiving tool for Unix systems, in 100% shell script." |
| 2 | DESCRIPTION = "\ |
| 3 | makeself.sh is a small shell script that generates a self-extractable \ |
| 4 | compressed tar archive from a directory. The resulting file appears as \ |
| 5 | a shell script (many of those have a .run suffix), and can be launched as is.\ |
| 6 | " |
| 7 | HOMEPAGE = "https://makeself.io/" |
| 8 | LICENSE = "GPL-2.0-only" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 10 | |
| 11 | SRC_URI = "\ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 12 | git://github.com/megastep/${BPN}.git;protocol=https;branch=master \ |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 13 | " |
| 14 | |
| 15 | SRCREV = "5742be6410bfad2c619fb1e98bf795e8fa0913c7" |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | do_configure[noexec] = "1" |
| 20 | do_compile[noexec] = "1" |
| 21 | |
| 22 | do_install() { |
| 23 | install -d ${D}${bindir} |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 24 | install -m 0755 ${S}/makeself.sh ${D}${bindir}/ |
| 25 | install -m 0755 ${S}/makeself-header.sh ${D}${bindir}/ |
| 26 | } |
| 27 | |
| 28 | BBCLASSEXTEND = "native" |