Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "F Virtual Window Manager " |
| 2 | HOMEPAGE = "http://www.fvwm.org/" |
| 3 | SECTION = "x11/wm" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 4 | LICENSE = "GPL-2.0-only" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=f8204787357db6ea518dcc9b6cf08388" |
| 6 | |
| 7 | DEPENDS = " \ |
| 8 | bison-native \ |
| 9 | flex-native \ |
| 10 | freetype-native \ |
| 11 | gettext-native \ |
| 12 | libxslt-native \ |
| 13 | fontconfig \ |
| 14 | libice \ |
| 15 | libpng \ |
| 16 | librsvg \ |
| 17 | libsm \ |
| 18 | libxau \ |
| 19 | libxcb \ |
| 20 | libxcursor \ |
| 21 | libxdmcp \ |
| 22 | libxext \ |
| 23 | libxfixes \ |
| 24 | libxft \ |
| 25 | libxinerama \ |
| 26 | libxml2 \ |
| 27 | libxrender \ |
| 28 | libxt \ |
| 29 | virtual/libx11 \ |
| 30 | xrandr \ |
| 31 | zlib \ |
| 32 | " |
| 33 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 34 | SRC_URI = " \ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 35 | git://github.com/fvwmorg/fvwm.git;protocol=https;branch=master \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 36 | file://0001-Fix-compilation-for-disabled-gnome.patch \ |
| 37 | " |
| 38 | |
Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame^] | 39 | SRCREV = "7baf540e56fb1a3e91752acba872a88543529d46" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 40 | |
| 41 | S = "${WORKDIR}/git" |
| 42 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 43 | inherit autotools gettext update-alternatives pkgconfig python3native perlnative features_check |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 44 | # depends on virtual/libx11 |
| 45 | REQUIRED_DISTRO_FEATURES = "x11" |
| 46 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 47 | ALTERNATIVE:${PN} = "x-window-manager" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 48 | ALTERNATIVE_TARGET[x-window-manager] = "${bindir}/fvwm" |
| 49 | ALTERNATIVE_PRIORITY[x-window-manager] = "20" |
| 50 | |
| 51 | EXTRA_OECONF = " \ |
| 52 | --disable-bidi \ |
| 53 | --disable-fontconfigtest \ |
| 54 | --disable-htmldoc \ |
| 55 | --disable-imlibtest \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 56 | --disable-nls \ |
| 57 | --disable-perllib \ |
| 58 | --disable-rsvg \ |
| 59 | --disable-shape \ |
| 60 | --disable-sm \ |
| 61 | --disable-xfttest \ |
| 62 | --with-imlib-exec-prefix=/nonexistent \ |
| 63 | --with-imlib-prefix=/nonexistent \ |
| 64 | --without-ncurses-library \ |
| 65 | --without-readline-library \ |
| 66 | --without-rplay-library \ |
| 67 | --without-stroke-library \ |
| 68 | --without-termcap-library \ |
| 69 | --without-xpm-library \ |
| 70 | ac_cv_func_mkstemp=no \ |
| 71 | has_safety_mkstemp=yes \ |
| 72 | " |
| 73 | |
| 74 | # show the exact commands in the log file |
| 75 | EXTRA_OEMAKE = " \ |
| 76 | V=1 \ |
| 77 | " |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 78 | # clang treats them as errors by default now starting with 15.0+ |
| 79 | CFLAGS += "-Wno-error=int-conversion -Wno-error=implicit-int" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 80 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 81 | do_install:append() { |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 82 | install -d -m 0755 ${D}/${sysconfdir}/xdg/fvwm |
| 83 | # You can install the config file here |
| 84 | |
| 85 | install -d -m 0755 ${D}/${datadir}/fvwm |
| 86 | touch ${D}/${datadir}/fvwm/ConfigFvwmDefaults |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 87 | sed -i -e 's:${STAGING_BINDIR_NATIVE}/perl-native/perl:${USRBINPATH}/env perl:g' ${D}${bindir}/fvwm-* |
| 88 | sed -i -e 's:${STAGING_BINDIR_NATIVE}/perl-native/perl:${USRBINPATH}/env perl:g' ${D}${libexecdir}/fvwm/*/Fvwm* |
| 89 | sed -i -e 's:${STAGING_BINDIR_NATIVE}/python3-native/python3:${USRBINPATH}/env python3:g' ${D}${bindir}/fvwm-menu-desktop |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 90 | } |
| 91 | |
| 92 | # the only needed packages (note: locale packages are automatically generated |
| 93 | # as well) |
| 94 | PACKAGES = " \ |
| 95 | ${PN} \ |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 96 | ${PN}-extra \ |
| 97 | ${PN}-doc \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 98 | ${PN}-dbg \ |
| 99 | " |
| 100 | |
| 101 | # minimal set of binaries |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 102 | FILES:${PN} = " \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 103 | ${bindir}/fvwm \ |
| 104 | ${bindir}/fvwm-root \ |
| 105 | ${datadir}/fvwm/ConfigFvwmDefaults \ |
| 106 | " |
| 107 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 108 | FILES:${PN}-extra = " \ |
| 109 | ${bindir} \ |
| 110 | ${libexecdir} \ |
| 111 | ${sysconfdir}/xdg/fvwm \ |
| 112 | " |
| 113 | FILES:${PN}-doc = " \ |
| 114 | ${mandir} \ |
| 115 | ${datadir}/fvwm \ |
| 116 | " |
| 117 | RDEPENDS:${PN} = " \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 118 | xuser-account \ |
| 119 | " |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 120 | RDEPENDS:${PN}-extra += "\ |
| 121 | perl \ |
| 122 | python3-core \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 123 | " |