Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame^] | 1 | SUMMARY = "Perl interface to allow reading and writing of compressed data." |
| 2 | DESCRIPTION = "This distribution provides a Perl interface to allow reading \ |
| 3 | and writing of compressed data created with the zlib and bzip2. \ |
| 4 | \ |
| 5 | IO-Compress supports reading and writing of the following compressed data \ |
| 6 | formats \ |
| 7 | * bzip2 \ |
| 8 | * RFC 1950 \ |
| 9 | * RFC 1951 \ |
| 10 | * RFC 1952 (i.e. gzip) \ |
| 11 | * zip \ |
| 12 | " |
| 13 | HOMEPAGE = "https://metacpan.org/release/IO-Compress" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 14 | SECTION = "libs" |
| 15 | LICENSE = "Artistic-1.0 | GPL-1.0-or-later" |
| 16 | |
Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame^] | 17 | LIC_FILES_CHKSUM = "file://README;beginline=8;endline=10;md5=36e282c4a4078cf2650d656cdda23210" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 18 | |
Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame^] | 19 | SRC_URI = "${CPAN_MIRROR}/authors/id/P/PM/PMQS/IO-Compress-${PV}.tar.gz" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 20 | |
| 21 | SRC_URI[md5sum] = "18ad197cad5ca87bc3a7d2538998e017" |
| 22 | SRC_URI[sha256sum] = "9d219fd5df4b490b5d2f847921e3cb1c3392758fa0bae9b05a8992b3620ba572" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 23 | |
| 24 | S = "${WORKDIR}/IO-Compress-${PV}" |
| 25 | |
| 26 | inherit cpan |
| 27 | |
Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame^] | 28 | RDEPENDS:${PN} += "\ |
| 29 | perl-module-bytes \ |
| 30 | perl-module-cwd \ |
| 31 | perl-module-encode \ |
| 32 | perl-module-file-glob \ |
| 33 | perl-module-file-spec \ |
| 34 | perl-module-posix \ |
| 35 | perl-module-scalar-util \ |
| 36 | perl-module-utf8 \ |
| 37 | libcompress-raw-bzip2-perl \ |
| 38 | libcompress-raw-zlib-perl \ |
| 39 | " |
| 40 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 41 | BBCLASSEXTEND = "native" |