Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 1 | SUMMARY = "JSON Web Token implementation in Python" |
| 2 | DESCRIPTION = "A Python implementation of JSON Web Token draft 32.\ |
| 3 | Original implementation was written by https://github.com/progrium" |
| 4 | HOMEPAGE = "http://github.com/jpadilla/pyjwt" |
| 5 | LICENSE = "MIT" |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e4b56d2c9973d8cf54655555be06e551" |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 7 | |
Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame^] | 8 | SRC_URI[sha256sum] = "69285c7e31fc44f68a1feb309e948e0df53259d579295e6cfe2b1792329f05fd" |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 9 | |
| 10 | PYPI_PACKAGE = "PyJWT" |
| 11 | inherit pypi setuptools3 |
| 12 | |
| 13 | RDEPENDS:${PN} = "${PYTHON_PN}-cryptography" |
| 14 | |
| 15 | BBCLASSEXTEND = "native nativesdk" |