Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 1 | SUMMARY = "Liberation(tm) Fonts" |
| 2 | DESCRIPTION = "The Liberation(tm) Fonts is a font family originally \ |
| 3 | created by Ascender(c) which aims at metric compatibility with \ |
| 4 | Arial, Times New Roman, Courier New." |
| 5 | HOMEPAGE = "https://github.com/liberationfonts/liberation-fonts" |
| 6 | BUGTRACKER = "https://bugzilla.redhat.com/" |
| 7 | |
| 8 | SECTION = "x11/fonts" |
| 9 | LICENSE = "OFL-1.1" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=f96db970a9a46c5369142b99f530366b" |
| 11 | PE = "1" |
| 12 | |
| 13 | SRC_URI = "https://github.com/liberationfonts/liberation-fonts/files/7261482/liberation-fonts-ttf-${PV}.tar.gz \ |
| 14 | file://30-liberation-aliases.conf" |
| 15 | SRC_URI[sha256sum] = "7191c669bf38899f73a2094ed00f7b800553364f90e2637010a69c0e268f25d0" |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 16 | GITHUB_BASE_URI = "https://github.com/liberationfonts/liberation-fonts/releases" |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 17 | |
| 18 | S = "${WORKDIR}/liberation-fonts-ttf-${PV}" |
| 19 | |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 20 | inherit allarch fontcache github-releases |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 21 | |
| 22 | do_install () { |
| 23 | install -d ${D}${datadir}/fonts/ttf/ |
| 24 | for i in *.ttf; do |
| 25 | install -m 0644 $i ${D}${prefix}/share/fonts/ttf/${i} |
| 26 | done |
| 27 | |
| 28 | install -d ${D}${sysconfdir}/fonts/conf.d/ |
| 29 | install -m 0644 ${WORKDIR}/30-liberation-aliases.conf ${D}${sysconfdir}/fonts/conf.d/ |
| 30 | |
| 31 | install -d ${D}${prefix}/share/doc/${BPN}/ |
| 32 | install -m 0644 LICENSE ${D}${datadir}/doc/${BPN}/ |
| 33 | } |
| 34 | |
| 35 | PACKAGES = "${PN}" |
| 36 | FILES:${PN} += "${sysconfdir} ${datadir}" |
| 37 | |
| 38 | BBCLASSEXTEND = "native nativesdk" |