Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Provides support for the Tag Image File Format (TIFF)" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | DESCRIPTION = "Library provides support for the Tag Image File Format \ |
| 3 | (TIFF), a widely used format for storing image data. This library \ |
| 4 | provide means to easily access and create TIFF image files." |
| 5 | HOMEPAGE = "http://www.libtiff.org/" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 6 | LICENSE = "BSD-2-Clause" |
| 7 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=34da3db46fab7501992f9615d7e158cf" |
| 8 | |
| 9 | CVE_PRODUCT = "libtiff" |
| 10 | |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 11 | SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \ |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 12 | file://0001-fix-the-FPE-in-tiffcrop-415-427-and-428.patch \ |
| 13 | file://CVE-2022-34526.patch \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 14 | file://CVE-2022-2953.patch \ |
Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame^] | 15 | file://0001-Revised-handling-of-TIFFTAG_INKNAMES-and-related-TIF.patch \ |
| 16 | file://0001-tiffcrop-S-option-Make-decision-simpler.patch \ |
| 17 | file://0001-tiffcrop-disable-incompatibility-of-Z-X-Y-z-options-.patch \ |
| 18 | file://0001-tiffcrop-subroutines-require-a-larger-buffer-fixes-2.patch \ |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 19 | " |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 20 | |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 21 | SRC_URI[sha256sum] = "917223b37538959aca3b790d2d73aa6e626b688e02dcda272aec24c2f498abed" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 22 | |
| 23 | # exclude betas |
| 24 | UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar" |
| 25 | |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 26 | # Tested with check from https://security-tracker.debian.org/tracker/CVE-2015-7313 |
| 27 | # and 4.3.0 doesn't have the issue |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 28 | CVE_CHECK_IGNORE += "CVE-2015-7313" |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 29 | # These issues only affect libtiff post-4.3.0 but before 4.4.0, |
| 30 | # caused by 3079627e and fixed by b4e79bfa. |
| 31 | CVE_CHECK_IGNORE += "CVE-2022-1622 CVE-2022-1623" |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 32 | # Issue is in jbig which we don't enable |
| 33 | CVE_CHECK_IGNORE += "CVE-2022-1210" |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 34 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 35 | inherit autotools multilib_header |
| 36 | |
| 37 | CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no" |
| 38 | |
| 39 | PACKAGECONFIG ?= "cxx jpeg zlib lzma \ |
| 40 | strip-chopping extrasample-as-alpha check-ycbcr-subsampling" |
| 41 | |
| 42 | PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,," |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 43 | PACKAGECONFIG[jbig] = "--enable-jbig,--disable-jbig,jbig," |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 44 | PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg," |
| 45 | PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib," |
| 46 | PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz," |
| 47 | |
| 48 | # Convert single-strip uncompressed images to multiple strips of specified |
| 49 | # size (default: 8192) to reduce memory usage |
| 50 | PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,," |
| 51 | |
| 52 | # Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA |
| 53 | PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,," |
| 54 | |
| 55 | # Control picking up YCbCr subsample info. Disable to support files lacking |
| 56 | # the tag |
| 57 | PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,," |
| 58 | |
| 59 | # Support a mechanism allowing reading large strips (usually one strip files) |
| 60 | # in chunks when using TIFFReadScanline. Experimental 4.0+ feature |
| 61 | PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,," |
| 62 | |
| 63 | PACKAGES =+ "tiffxx tiff-utils" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 64 | FILES:tiffxx = "${libdir}/libtiffxx.so.*" |
| 65 | FILES:tiff-utils = "${bindir}/*" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 66 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 67 | do_install:append() { |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 68 | oe_multilib_header tiffconf.h |
| 69 | } |
| 70 | |
Andrew Geissler | 4ed12e1 | 2020-06-05 18:00:41 -0500 | [diff] [blame] | 71 | BBCLASSEXTEND = "native nativesdk" |