Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | SUMMARY = "WPE's backend based on a freedesktop.org stack." |
| 2 | HOMEPAGE = "https://github.com/Igalia/WPEBackend-fdo" |
| 3 | BUGTRACKER = "https://github.com/Igalia/WPEBackend-fdo/issues" |
| 4 | |
| 5 | LICENSE = "BSD-2-Clause" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=1f62cef2e3645e3e74eb05fd389d7a66" |
| 7 | DEPENDS = "glib-2.0 libxkbcommon wayland virtual/egl libwpe libepoxy" |
| 8 | |
| 9 | DEPENDS:append:class-target = " wayland-native" |
| 10 | |
| 11 | inherit meson features_check pkgconfig |
| 12 | |
| 13 | REQUIRED_DISTRO_FEATURES = "opengl" |
| 14 | |
| 15 | SRC_URI = "https://wpewebkit.org/releases/${BPN}-${PV}.tar.xz" |
Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame^] | 16 | SRC_URI[sha256sum] = "e75b0cb2c7145448416e8696013d8883f675c66c11ed750e06865efec5809155" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 17 | |
| 18 | # Especially helps compiling with clang which enable this as error when |
| 19 | # using c++11 |
| 20 | CXXFLAGS += "-Wno-c++11-narrowing" |
| 21 | |
| 22 | # This is a tweak of upstream-version-is-even needed because |
| 23 | # ipstream directory contains tarballs for other components as well. |
| 24 | UPSTREAM_CHECK_REGEX = "wpebackend-fdo-(?P<pver>\d+\.(\d*[02468])+(\.\d+)+)\.tar" |