Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "User space daemon for extended IEEE 802.11 management" |
| 2 | HOMEPAGE = "http://w1.fi/hostapd/" |
| 3 | SECTION = "kernel/userland" |
| 4 | LICENSE = "BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://hostapd/README;md5=1ec986bec88070e2a59c68c95d763f89" |
| 6 | |
| 7 | DEPENDS = "libnl openssl" |
| 8 | |
| 9 | SRC_URI = " \ |
| 10 | http://w1.fi/releases/hostapd-${PV}.tar.gz \ |
| 11 | file://defconfig \ |
| 12 | file://init \ |
| 13 | file://hostapd.service \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 14 | file://CVE-2019-16275.patch \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 15 | " |
| 16 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 17 | SRC_URI[md5sum] = "f188fc53a495fe7af3b6d77d3c31dee8" |
| 18 | SRC_URI[sha256sum] = "881d7d6a90b2428479288d64233151448f8990ab4958e0ecaca7eeb3c9db2bd7" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 19 | |
| 20 | S = "${WORKDIR}/hostapd-${PV}" |
| 21 | B = "${WORKDIR}/hostapd-${PV}/hostapd" |
| 22 | |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 23 | inherit update-rc.d systemd pkgconfig features_check |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 24 | |
| 25 | CONFLICT_DISTRO_FEATURES = "openssl-no-weak-ciphers" |
| 26 | |
| 27 | INITSCRIPT_NAME = "hostapd" |
| 28 | |
| 29 | SYSTEMD_SERVICE_${PN} = "hostapd.service" |
| 30 | SYSTEMD_AUTO_ENABLE_${PN} = "disable" |
| 31 | |
| 32 | do_configure_append() { |
| 33 | install -m 0644 ${WORKDIR}/defconfig ${B}/.config |
| 34 | } |
| 35 | |
| 36 | do_compile() { |
| 37 | export CFLAGS="-MMD -O2 -Wall -g" |
| 38 | export EXTRA_CFLAGS="${CFLAGS}" |
| 39 | make V=1 |
| 40 | } |
| 41 | |
| 42 | do_install() { |
| 43 | install -d ${D}${sbindir} ${D}${sysconfdir}/init.d ${D}${systemd_unitdir}/system/ |
| 44 | install -m 0644 ${B}/hostapd.conf ${D}${sysconfdir} |
| 45 | install -m 0755 ${B}/hostapd ${D}${sbindir} |
| 46 | install -m 0755 ${B}/hostapd_cli ${D}${sbindir} |
| 47 | install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/hostapd |
| 48 | install -m 0644 ${WORKDIR}/hostapd.service ${D}${systemd_unitdir}/system/ |
| 49 | sed -i -e 's,@SBINDIR@,${sbindir},g' -e 's,@SYSCONFDIR@,${sysconfdir},g' ${D}${systemd_unitdir}/system/hostapd.service |
| 50 | } |
| 51 | |
| 52 | CONFFILES_${PN} += "${sysconfdir}/hostapd.conf" |