blob: 68dc12370253b203b6829b9afb856de80b4f06ef [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "User space daemon for extended IEEE 802.11 management"
2HOMEPAGE = "http://w1.fi/hostapd/"
3SECTION = "kernel/userland"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://hostapd/README;md5=1ec986bec88070e2a59c68c95d763f89"
6
7DEPENDS = "libnl openssl"
8
9SRC_URI = " \
10 http://w1.fi/releases/hostapd-${PV}.tar.gz \
11 file://defconfig \
12 file://init \
13 file://hostapd.service \
Andrew Geissler82c905d2020-04-13 13:39:40 -050014 file://CVE-2019-16275.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040015"
16
Brad Bishop26bdd442019-08-16 17:08:17 -040017SRC_URI[md5sum] = "f188fc53a495fe7af3b6d77d3c31dee8"
18SRC_URI[sha256sum] = "881d7d6a90b2428479288d64233151448f8990ab4958e0ecaca7eeb3c9db2bd7"
Brad Bishopc342db32019-05-15 21:57:59 -040019
20S = "${WORKDIR}/hostapd-${PV}"
21B = "${WORKDIR}/hostapd-${PV}/hostapd"
22
Brad Bishop8410d612019-11-25 09:40:59 -050023inherit update-rc.d systemd pkgconfig features_check
Brad Bishopc342db32019-05-15 21:57:59 -040024
25CONFLICT_DISTRO_FEATURES = "openssl-no-weak-ciphers"
26
27INITSCRIPT_NAME = "hostapd"
28
29SYSTEMD_SERVICE_${PN} = "hostapd.service"
30SYSTEMD_AUTO_ENABLE_${PN} = "disable"
31
32do_configure_append() {
33 install -m 0644 ${WORKDIR}/defconfig ${B}/.config
34}
35
36do_compile() {
37 export CFLAGS="-MMD -O2 -Wall -g"
38 export EXTRA_CFLAGS="${CFLAGS}"
39 make V=1
40}
41
42do_install() {
43 install -d ${D}${sbindir} ${D}${sysconfdir}/init.d ${D}${systemd_unitdir}/system/
44 install -m 0644 ${B}/hostapd.conf ${D}${sysconfdir}
45 install -m 0755 ${B}/hostapd ${D}${sbindir}
46 install -m 0755 ${B}/hostapd_cli ${D}${sbindir}
47 install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/hostapd
48 install -m 0644 ${WORKDIR}/hostapd.service ${D}${systemd_unitdir}/system/
49 sed -i -e 's,@SBINDIR@,${sbindir},g' -e 's,@SYSCONFDIR@,${sysconfdir},g' ${D}${systemd_unitdir}/system/hostapd.service
50}
51
52CONFFILES_${PN} += "${sysconfdir}/hostapd.conf"