Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 1 | SUMMARY = "Zstandard - Fast real-time compression algorithm" |
| 2 | DESCRIPTION = "Zstandard is a fast lossless compression algorithm, targeting \ |
| 3 | real-time compression scenarios at zlib-level and better compression ratios. \ |
| 4 | It's backed by a very fast entropy stage, provided by Huff0 and FSE library." |
| 5 | HOMEPAGE = "http://www.zstd.net/" |
| 6 | SECTION = "console/utils" |
| 7 | |
| 8 | LICENSE = "BSD-3-Clause & GPLv2" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c7f0b161edbe52f5f345a3d1311d0b32 \ |
| 10 | file://COPYING;md5=39bba7d2cf0ba1036f2a6e2be52fe3f0" |
| 11 | |
Andrew Geissler | 97771a3 | 2021-03-05 15:23:11 -0600 | [diff] [blame] | 12 | inherit lib_package |
| 13 | |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 14 | SRC_URI = "git://github.com/facebook/zstd.git;nobranch=1 \ |
| 15 | file://0001-Fix-legacy-build-after-2103.patch \ |
| 16 | " |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 17 | |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 18 | SRCREV = "b706286adbba780006a47ef92df0ad7a785666b6" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 19 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)" |
| 20 | |
| 21 | S = "${WORKDIR}/git" |
| 22 | |
| 23 | PACKAGECONFIG ??= "" |
| 24 | PACKAGECONFIG[lz4] = "HAVE_LZ4=1,HAVE_LZ4=0,lz4" |
| 25 | PACKAGECONFIG[lzma] = "HAVE_LZMA=1,HAVE_LZMA=0,xz" |
| 26 | PACKAGECONFIG[zlib] = "HAVE_ZLIB=1,HAVE_ZLIB=0,zlib" |
| 27 | |
| 28 | # See programs/README.md for how to use this |
| 29 | ZSTD_LEGACY_SUPPORT ??= "4" |
| 30 | |
| 31 | do_compile () { |
| 32 | oe_runmake ${PACKAGECONFIG_CONFARGS} ZSTD_LEGACY_SUPPORT=${ZSTD_LEGACY_SUPPORT} |
| 33 | } |
| 34 | |
| 35 | do_install () { |
| 36 | oe_runmake install 'DESTDIR=${D}' |
| 37 | } |
| 38 | |
| 39 | BBCLASSEXTEND = "native nativesdk" |