blob: d0cc625aad318b4d2030ccc73d356db3439a07d9 [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "Zstandard - Fast real-time compression algorithm"
2DESCRIPTION = "Zstandard is a fast lossless compression algorithm, targeting \
3real-time compression scenarios at zlib-level and better compression ratios. \
4It's backed by a very fast entropy stage, provided by Huff0 and FSE library."
5HOMEPAGE = "http://www.zstd.net/"
6SECTION = "console/utils"
7
8LICENSE = "BSD-3-Clause & GPLv2"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=c7f0b161edbe52f5f345a3d1311d0b32 \
10 file://COPYING;md5=39bba7d2cf0ba1036f2a6e2be52fe3f0"
11
Andrew Geissler97771a32021-03-05 15:23:11 -060012inherit lib_package
13
Andrew Geisslerc87764f2020-06-27 00:16:32 -050014SRC_URI = "git://github.com/facebook/zstd.git;nobranch=1 \
15 file://0001-Fix-legacy-build-after-2103.patch \
16 "
Brad Bishope42b3e32020-01-15 22:08:42 -050017
Andrew Geisslerc87764f2020-06-27 00:16:32 -050018SRCREV = "b706286adbba780006a47ef92df0ad7a785666b6"
Brad Bishope42b3e32020-01-15 22:08:42 -050019UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
20
21S = "${WORKDIR}/git"
22
23PACKAGECONFIG ??= ""
24PACKAGECONFIG[lz4] = "HAVE_LZ4=1,HAVE_LZ4=0,lz4"
25PACKAGECONFIG[lzma] = "HAVE_LZMA=1,HAVE_LZMA=0,xz"
26PACKAGECONFIG[zlib] = "HAVE_ZLIB=1,HAVE_ZLIB=0,zlib"
27
28# See programs/README.md for how to use this
29ZSTD_LEGACY_SUPPORT ??= "4"
30
31do_compile () {
32 oe_runmake ${PACKAGECONFIG_CONFARGS} ZSTD_LEGACY_SUPPORT=${ZSTD_LEGACY_SUPPORT}
33}
34
35do_install () {
36 oe_runmake install 'DESTDIR=${D}'
37}
38
39BBCLASSEXTEND = "native nativesdk"