Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | DESCRIPTION = "gvfs is a userspace virtual filesystem" |
| 2 | LICENSE = "LGPLv2" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=05df38dd77c35ec8431f212410a3329e" |
| 4 | |
| 5 | inherit gnome bash-completion gettext |
| 6 | |
| 7 | DEPENDS += "libsecret glib-2.0 gconf intltool-native libgudev udisks2 polkit shadow-native" |
| 8 | |
| 9 | SRC_URI = "https://download.gnome.org/sources/${BPN}/${@gnome_verdir("${PV}")}/${BPN}-${PV}.tar.xz;name=archive" |
| 10 | |
| 11 | SRC_URI[archive.md5sum] = "216d461c5e96e2cea74253be407af6dc" |
| 12 | SRC_URI[archive.sha256sum] = "9ec388afeb373a213f2cc489184f76a17ae273a000e8a4ec720c1995943256bb" |
| 13 | |
| 14 | do_configure_prepend() { |
| 15 | # make automake happy.. |
| 16 | touch ${S}/ABOUT-NLS |
| 17 | } |
| 18 | |
| 19 | EXTRA_OECONF = " \ |
| 20 | --disable-gdu \ |
| 21 | --enable-udisks2 \ |
| 22 | --disable-documentation \ |
| 23 | " |
| 24 | |
| 25 | PACKAGES =+ "gvfsd-ftp gvfsd-sftp gvfsd-trash" |
| 26 | |
| 27 | FILES_${PN} += " \ |
| 28 | ${datadir}/glib-2.0 \ |
| 29 | ${datadir}/GConf \ |
| 30 | ${datadir}/dbus-1/services \ |
| 31 | ${libdir}/gio/modules/*.so \ |
| 32 | ${libdir}/tmpfiles.d \ |
| 33 | ${systemd_user_unitdir} \ |
| 34 | " |
| 35 | RDEPENDS_${PN} = "udisks2" |
| 36 | |
| 37 | FILES_${PN}-dbg += "${libdir}/gio/modules/.debug/*" |
| 38 | FILES_${PN}-dev += "${libdir}/gio/modules/*.la" |
| 39 | |
| 40 | FILES_gvfsd-ftp = "${libexecdir}/gvfsd-ftp ${datadir}/gvfs/mounts/ftp.mount" |
| 41 | FILES_gvfsd-sftp = "${libexecdir}/gvfsd-sftp ${datadir}/gvfs/mounts/sftp.mount" |
| 42 | FILES_gvfsd-trash = "${libexecdir}/gvfsd-trash ${datadir}/gvfs/mounts/trash.mount" |
| 43 | |
| 44 | RRECOMMENDS_gvfsd-ftp += "openssh-sftp openssh-ssh" |
| 45 | |
| 46 | PACKAGECONFIG ?= "libgphoto2 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" |
| 47 | |
| 48 | PACKAGECONFIG[afc] = "--enable-afc, --disable-afc, libimobiledevice libplist" |
| 49 | PACKAGECONFIG[archive] = "--enable-archive, --disable-archive, libarchive" |
| 50 | PACKAGECONFIG[avahi] = "--enable-avahi, --disable-avahi, avahi" |
| 51 | PACKAGECONFIG[gcr] = "--enable-gcr, --disable-gcr, gcr" |
| 52 | PACKAGECONFIG[http] = "--enable-http, --disable-http, libsoup-2.4" |
| 53 | PACKAGECONFIG[libmtp] = "--enable-libmtp, --disable-libmtp, libmtp" |
| 54 | PACKAGECONFIG[libgphoto2] = "--enable-gphoto2, --disable-gphoto2, libgphoto2" |
| 55 | PACKAGECONFIG[samba] = "--enable-samba, --disable-samba, samba" |
| 56 | PACKAGECONFIG[systemd] = "--with-systemduserunitdir=${systemd_user_unitdir},--without-systemduserunitdir,systemd" |
| 57 | |
| 58 | # needs meta-filesystems |
| 59 | PACKAGECONFIG[fuse] = "--enable-fuse, --disable-fuse, fuse" |
| 60 | |
| 61 | # libcdio-paranoia recipe doesn't exist yet |
| 62 | PACKAGECONFIG[cdda] = "--enable-cdda, --disable-cdda, libcdio-paranoia" |
| 63 | |
| 64 | # Fix up permissions on polkit rules.d to work with rpm4 constraints |
| 65 | do_install_append() { |
| 66 | chmod 700 ${D}/${datadir}/polkit-1/rules.d |
| 67 | chown polkitd:root ${D}/${datadir}/polkit-1/rules.d |
| 68 | } |